summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf/distro/openslug-packages.conf2
-rw-r--r--conf/machine/ipaq-pxa270.conf32
-rw-r--r--packages/ipkg/ipkg-0.99.138/terse.patch18
-rw-r--r--packages/ipkg/ipkg-0.99.140/terse.patch18
-rw-r--r--packages/ipkg/ipkg-0.99.144/terse.patch18
-rw-r--r--packages/ipkg/ipkg-0.99.146/.mtn2git_empty0
-rw-r--r--packages/ipkg/ipkg-0.99.146/terse.patch18
-rw-r--r--packages/ipkg/ipkg-0.99.147/terse.patch18
-rw-r--r--packages/ipkg/ipkg-0.99.148/terse.patch18
-rw-r--r--packages/ipkg/ipkg-0.99.151/.mtn2git_empty0
-rw-r--r--packages/ipkg/ipkg-0.99.151/terse.patch18
-rw-r--r--packages/ipkg/ipkg-native_0.99.152.bb13
-rw-r--r--packages/ipkg/ipkg/.mtn2git_empty (renamed from packages/ipkg/ipkg-0.99.138/.mtn2git_empty)0
-rw-r--r--packages/ipkg/ipkg/terse.patch (renamed from packages/ipkg/ipkg-0.99.135/terse.patch)0
-rw-r--r--packages/ipkg/ipkg_0.99.152.bb54
-rw-r--r--packages/meta/openslug-packages.bb3
-rw-r--r--packages/python/python-scapy_0.9.17.bb2
-rw-r--r--packages/rsync/rsync-2.6.3/.mtn2git_empty0
-rw-r--r--packages/rsync/rsync-2.6.3/fixedwidthtypes.patch35
19 files changed, 89 insertions, 178 deletions
diff --git a/conf/distro/openslug-packages.conf b/conf/distro/openslug-packages.conf
index daff83460b..e4da231aa5 100644
--- a/conf/distro/openslug-packages.conf
+++ b/conf/distro/openslug-packages.conf
@@ -1,5 +1,6 @@
# automatically generated by bitbake freeze
BBFILES := "\
+${PKGDIR}/packages/atftp/*.bb \
${PKGDIR}/packages/audiofile/*.bb \
${PKGDIR}/packages/autoconf/*.bb \
${PKGDIR}/packages/automake/*.bb \
@@ -134,6 +135,7 @@ ${PKGDIR}/packages/samba/*.bb \
${PKGDIR}/packages/sane-backends/*.bb \
${PKGDIR}/packages/screen/*.bb \
${PKGDIR}/packages/sed/*.bb \
+${PKGDIR}/packages/setpwc/*.bb \
${PKGDIR}/packages/slugimage/*.bb \
${PKGDIR}/packages/streamripper/*.bb \
${PKGDIR}/packages/sudo/*.bb \
diff --git a/conf/machine/ipaq-pxa270.conf b/conf/machine/ipaq-pxa270.conf
index 58a178850b..da7952d994 100644
--- a/conf/machine/ipaq-pxa270.conf
+++ b/conf/machine/ipaq-pxa270.conf
@@ -2,30 +2,32 @@
#@NAME: iPAQ hx47xx hx2xxx
#@DESCRIPTION: Machine configuration for the iPAQ with a pxa27x CPU devices
-
TARGET_ARCH = "arm"
-IPKG_ARCHS = "all arm ipaqpxa hx4700"
-PREFERRED_PROVIDER_xserver = "xserver-kdrive"
-PREFERRED_PROVIDER_virtual/kernel = "handhelds-pxa"
-EXTRA_IMAGECMD_h3900_jffs2 = "-e 0x40000 -p"
+IPKG_ARCHS = "all arm armv4 armv5te ipaqpxa hx4700"
+PREFERRED_PROVIDER_virtual/kernel = "handhelds-pxa-2.6"
+
+PREFERRED_VERSION_orinoco-modules = "0.15rc1"
BOOTSTRAP_EXTRA_DEPENDS = "ipaq-boot-params"
-BOOTSTRAP_EXTRA_DEPENDS_append = " handhelds-pxa-2.6 udev module-init-tools"
+BOOTSTRAP_EXTRA_DEPENDS_append = " handhelds-pxa-2.6 udev modutils-collateral module-init-tools"
BOOTSTRAP_EXTRA_RDEPENDS = "kernel ipaq-boot-params ${@linux_module_packages('${PXA270_MODULES}', d)}"
-BOOTSTRAP_EXTRA_RDEPENDS_append = " udev module-init-tools"
+BOOTSTRAP_EXTRA_RDEPENDS_append = " udev modutils-collateral module-init-tools"
-PXA270_MODULES = "g_ether pxa2xx_udc"
+PXA270_MODULES = "g_ether pxa27x_udc"
-
-SERIAL_CONSOLE = "115200 tts/0 vt100"
-USE_DEVFS_kernel24 = "1"
-USE_VT = "0"
+SERIAL_CONSOLE = "115200 ttyS0"
include conf/machine/ipaq-common.conf
include conf/machine/handheld-common.conf
-GUI_MACHINE_CLASS = "largescreen"
+GUI_MACHINE_CLASS = "bigscreen"
+GPE_EXTRA_DEPENDS += "gaim sylpheed"
+GPE_EXTRA_INSTALL += "gaim sylpheed"
+
+# Use tune-xscale per default. Machine independent feeds should be built with tune-strongarm.
+include conf/machine/tune-xscale.conf
-# not using tune-xscale so as to retain backwards compatibility
-include conf/machine/tune-strongarm.conf
+BOOTSTRAP_EXTRA_RDEPENDS += "${@linux_module_packages('${HX4700_MODULES}', d)}"
+HX4700_MODULES = "asic3_base asic3_mmc hx4700_bt hx4700_core hx4700_leds hx4700_navpt hx4700_pcmcia \
+ hx4700_ts hx4700_wlan snd_pxa_i2sound_hx4700"
diff --git a/packages/ipkg/ipkg-0.99.138/terse.patch b/packages/ipkg/ipkg-0.99.138/terse.patch
deleted file mode 100644
index 3c4d6bed7e..0000000000
--- a/packages/ipkg/ipkg-0.99.138/terse.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- C/ipkg_cmd.c~terse
-+++ C/ipkg_cmd.c
-@@ -148,9 +146,7 @@
- int result;
- p_userdata = userdata;
- result = (cmd->fun)(conf, argc, argv);
-- if ( result == 0 ) {
-- ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n");
-- } else {
-+ if ( result != 0 ) {
- ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result);
- }
-
diff --git a/packages/ipkg/ipkg-0.99.140/terse.patch b/packages/ipkg/ipkg-0.99.140/terse.patch
deleted file mode 100644
index 3c4d6bed7e..0000000000
--- a/packages/ipkg/ipkg-0.99.140/terse.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- C/ipkg_cmd.c~terse
-+++ C/ipkg_cmd.c
-@@ -148,9 +146,7 @@
- int result;
- p_userdata = userdata;
- result = (cmd->fun)(conf, argc, argv);
-- if ( result == 0 ) {
-- ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n");
-- } else {
-+ if ( result != 0 ) {
- ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result);
- }
-
diff --git a/packages/ipkg/ipkg-0.99.144/terse.patch b/packages/ipkg/ipkg-0.99.144/terse.patch
deleted file mode 100644
index 3c4d6bed7e..0000000000
--- a/packages/ipkg/ipkg-0.99.144/terse.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- C/ipkg_cmd.c~terse
-+++ C/ipkg_cmd.c
-@@ -148,9 +146,7 @@
- int result;
- p_userdata = userdata;
- result = (cmd->fun)(conf, argc, argv);
-- if ( result == 0 ) {
-- ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n");
-- } else {
-+ if ( result != 0 ) {
- ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result);
- }
-
diff --git a/packages/ipkg/ipkg-0.99.146/.mtn2git_empty b/packages/ipkg/ipkg-0.99.146/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ipkg/ipkg-0.99.146/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ipkg/ipkg-0.99.146/terse.patch b/packages/ipkg/ipkg-0.99.146/terse.patch
deleted file mode 100644
index 3c4d6bed7e..0000000000
--- a/packages/ipkg/ipkg-0.99.146/terse.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- C/ipkg_cmd.c~terse
-+++ C/ipkg_cmd.c
-@@ -148,9 +146,7 @@
- int result;
- p_userdata = userdata;
- result = (cmd->fun)(conf, argc, argv);
-- if ( result == 0 ) {
-- ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n");
-- } else {
-+ if ( result != 0 ) {
- ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result);
- }
-
diff --git a/packages/ipkg/ipkg-0.99.147/terse.patch b/packages/ipkg/ipkg-0.99.147/terse.patch
deleted file mode 100644
index 3c4d6bed7e..0000000000
--- a/packages/ipkg/ipkg-0.99.147/terse.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- C/ipkg_cmd.c~terse
-+++ C/ipkg_cmd.c
-@@ -148,9 +146,7 @@
- int result;
- p_userdata = userdata;
- result = (cmd->fun)(conf, argc, argv);
-- if ( result == 0 ) {
-- ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n");
-- } else {
-+ if ( result != 0 ) {
- ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result);
- }
-
diff --git a/packages/ipkg/ipkg-0.99.148/terse.patch b/packages/ipkg/ipkg-0.99.148/terse.patch
deleted file mode 100644
index 3c4d6bed7e..0000000000
--- a/packages/ipkg/ipkg-0.99.148/terse.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- C/ipkg_cmd.c~terse
-+++ C/ipkg_cmd.c
-@@ -148,9 +146,7 @@
- int result;
- p_userdata = userdata;
- result = (cmd->fun)(conf, argc, argv);
-- if ( result == 0 ) {
-- ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n");
-- } else {
-+ if ( result != 0 ) {
- ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result);
- }
-
diff --git a/packages/ipkg/ipkg-0.99.151/.mtn2git_empty b/packages/ipkg/ipkg-0.99.151/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ipkg/ipkg-0.99.151/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ipkg/ipkg-0.99.151/terse.patch b/packages/ipkg/ipkg-0.99.151/terse.patch
deleted file mode 100644
index 3c4d6bed7e..0000000000
--- a/packages/ipkg/ipkg-0.99.151/terse.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- C/ipkg_cmd.c~terse
-+++ C/ipkg_cmd.c
-@@ -148,9 +146,7 @@
- int result;
- p_userdata = userdata;
- result = (cmd->fun)(conf, argc, argv);
-- if ( result == 0 ) {
-- ipkg_message(conf, IPKG_NOTICE, "Successfully terminated.\n");
-- } else {
-+ if ( result != 0 ) {
- ipkg_message(conf, IPKG_NOTICE, "An error ocurred, return value: %d.\n", result);
- }
-
diff --git a/packages/ipkg/ipkg-native_0.99.152.bb b/packages/ipkg/ipkg-native_0.99.152.bb
new file mode 100644
index 0000000000..3011b32b75
--- /dev/null
+++ b/packages/ipkg/ipkg-native_0.99.152.bb
@@ -0,0 +1,13 @@
+SECTION = "base"
+include ipkg_${PV}.bb
+
+# NOTE: ipkg now obeys ${libdir}, so ipkg-native now installs
+# things into the wrong location inside of offline_root. Backup
+# the target libdir and use that.
+target_libdir := "${libdir}"
+
+inherit native
+
+DEPENDS = "libtool-native automake-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/ipkg-${PV}"
+PROVIDES = ""
diff --git a/packages/ipkg/ipkg-0.99.138/.mtn2git_empty b/packages/ipkg/ipkg/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/ipkg/ipkg-0.99.138/.mtn2git_empty
+++ b/packages/ipkg/ipkg/.mtn2git_empty
diff --git a/packages/ipkg/ipkg-0.99.135/terse.patch b/packages/ipkg/ipkg/terse.patch
index 3c4d6bed7e..3c4d6bed7e 100644
--- a/packages/ipkg/ipkg-0.99.135/terse.patch
+++ b/packages/ipkg/ipkg/terse.patch
diff --git a/packages/ipkg/ipkg_0.99.152.bb b/packages/ipkg/ipkg_0.99.152.bb
new file mode 100644
index 0000000000..684ff784b3
--- /dev/null
+++ b/packages/ipkg/ipkg_0.99.152.bb
@@ -0,0 +1,54 @@
+SECTION = "base"
+DESCRIPTION = "Itsy Package Manager"
+DESCRIPTION_libipkg = "Itsy Package Manager Library"
+LICENSE = "GPL"
+PROVIDES = "virtual/ipkg libipkg"
+PR = "r0"
+
+PACKAGES =+ "libipkg-dev libipkg"
+FILES_libipkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
+FILES_libipkg = "${libdir}"
+AUTO_LIBNAME_PKGS = "libipkg"
+
+SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVar('PV',d,1).replace('.', '-')} \
+ file://terse.patch;patch=1 "
+
+S = "${WORKDIR}/ipkg/C"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--with-ipkglibdir=/usr/lib"
+
+pkg_postinst_ipkg () {
+#!/bin/sh
+if [ "x$D" != "x" ]; then
+ install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
+ # this happens at S98 where our good 'ole packages script used to run
+ echo -e "#!/bin/sh
+ipkg-cl configure
+" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S98configure
+ chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S98configure
+fi
+
+update-alternatives --install ${bindir}/ipkg ipkg ${bindir}/ipkg-cl 100
+}
+
+pkg_postrm_ipkg () {
+#!/bin/sh
+update-alternatives --remove ipkg ${bindir}/ipkg-cl
+}
+
+do_stage() {
+ oe_libinstall -so libipkg ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/replace/
+ install -m 0644 replace/replace.h ${STAGING_INCDIR}/replace/
+ install -d ${STAGING_INCDIR}/libipkg/
+ for f in *.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/libipkg/
+ done
+}
+
+#
+# FIXME: Install /etc/ipkg.conf and /etc/ipkg/arch.conf
+#
diff --git a/packages/meta/openslug-packages.bb b/packages/meta/openslug-packages.bb
index 8f804abc19..96d81e1d31 100644
--- a/packages/meta/openslug-packages.bb
+++ b/packages/meta/openslug-packages.bb
@@ -46,6 +46,7 @@ OPENSLUG_DEVELOPMENT_append_linux = "\
OPENSLUG_PACKAGES = "\
+ atftp \
bash \
bluez-utils-nodbus \
bridge-utils \
@@ -81,6 +82,7 @@ OPENSLUG_PACKAGES = "\
pwc \
rsync \
screen \
+ setpwc \
streamripper \
sudo \
sysfsutils \
@@ -116,7 +118,6 @@ OPENSLUG_PACKAGES_append_linux = "\
"
BROKEN_PACKAGES = "\
- atftp \
strace \
"
diff --git a/packages/python/python-scapy_0.9.17.bb b/packages/python/python-scapy_0.9.17.bb
index 3d0d09d574..30b380d2f3 100644
--- a/packages/python/python-scapy_0.9.17.bb
+++ b/packages/python/python-scapy_0.9.17.bb
@@ -9,7 +9,7 @@ MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
RDEPENDS = "python-core python-netclient python-netserver"
SRCNAME = "scapy"
-SRC_URI = "http://www.cartel-securite.fr/pbiondi/python/scapy-${PV}.tar.gz"
+SRC_URI = "http://www.secdev.org/projects/scapy/files/scapy-${PV}.tar.gz"
S = "${WORKDIR}/${SRCNAME}-${PV}"
do_install() {
diff --git a/packages/rsync/rsync-2.6.3/.mtn2git_empty b/packages/rsync/rsync-2.6.3/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/rsync/rsync-2.6.3/.mtn2git_empty
+++ /dev/null
diff --git a/packages/rsync/rsync-2.6.3/fixedwidthtypes.patch b/packages/rsync/rsync-2.6.3/fixedwidthtypes.patch
deleted file mode 100644
index 9f7d3c804d..0000000000
--- a/packages/rsync/rsync-2.6.3/fixedwidthtypes.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- rsync-2.6.2/configure.in 2004-04-30 14:02:43.000000000 -0400
-+++ rsync-2.6.2/configure.in 2004-05-22 13:09:42.000000000 -0400
-@@ -307,6 +307,8 @@
- AC_CHECK_MEMBERS([struct stat.st_rdev])
-
- AC_CHECK_TYPE([ino_t], [unsigned])
-+AC_CHECK_TYPES([int64_t])
-+AC_CHECK_TYPES([uint64_t])
- TYPE_SOCKLEN_T
-
- AC_CACHE_CHECK([for errno in errno.h],rsync_cv_errno, [
---- rsync-2.6.2/rsync.h 2004-04-26 21:36:16.000000000 -0400
-+++ rsync-2.6.2/rsync.h 2004-05-22 13:06:16.000000000 -0400
-@@ -298,7 +298,9 @@
- #define STRUCT_STAT struct stat
- #endif
-
--#if HAVE_OFF64_T
-+#if defined(HAVE_INT64_T)
-+#define int64 int64_t
-+#elif HAVE_OFF64_T
- #define int64 off64_t
- #elif (SIZEOF_LONG == 8)
- #define int64 long
-@@ -312,7 +314,9 @@
- #define NO_INT64
- #endif
-
--#if (SIZEOF_LONG == 8)
-+#if defined(HAVE_UINT64_T)
-+#define uint64 uint64_t
-+#elif (SIZEOF_LONG == 8)
- #define uint64 unsigned long
- #elif (SIZEOF_INT == 8)
- #define uint64 unsigned int