summaryrefslogtreecommitdiff
path: root/sudo
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
committerChris Larson <clarson@kergoth.com>2004-11-09 00:36:47 +0000
commitf96441b9faf769c9ecdd4d338b605ea3d0cc4010 (patch)
treeedb17ec2c4ea13c5acb1c7350957a249a820e28d /sudo
parentb6588aa6851fb220cedc387d21c51513ef8d67f4 (diff)
Disable bk EOLN_NATIVE conversions on all files in packages FILESPATHs, to prevent it screwing up patches.
BKrev: 4190111fA4MuVozAqwE7xOSL9fr-TA
Diffstat (limited to 'sudo')
-rw-r--r--sudo/sudo-1.6.7p5/nonrootinstall.patch58
-rw-r--r--sudo/sudo-1.6.7p5/nostrip.patch27
2 files changed, 85 insertions, 0 deletions
diff --git a/sudo/sudo-1.6.7p5/nonrootinstall.patch b/sudo/sudo-1.6.7p5/nonrootinstall.patch
index e69de29bb2..45c40e6986 100644
--- a/sudo/sudo-1.6.7p5/nonrootinstall.patch
+++ b/sudo/sudo-1.6.7p5/nonrootinstall.patch
@@ -0,0 +1,58 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sudo-1.6.7p5/Makefile.in~nonrootinstall
++++ sudo-1.6.7p5/Makefile.in
+@@ -64,7 +64,7 @@
+ # C preprocessor flags
+ CPPFLAGS = -I. -I$(srcdir) @CPPFLAGS@
+
+-# Usually -O and/or -g
++# Usually -o and/or -g
+ CFLAGS = @CFLAGS@
+
+ # Flags to pass to the link stage
+@@ -96,10 +96,16 @@
+ mandirform = $(mandir)/$(mantype)$(mansectform)
+
+ # User and group ids the installed files should be "owned" by
++ifeq ($(DESTDIR),)
++install_owncmd = -o $(install_uid) -g $(install_gid)
++endif
+ install_uid = 0
+ install_gid = 0
+
+ # User, group, and mode the sudoers file should be "owned" by (configure)
++ifeq ($(DESTDIR),)
++sudoers_owncmd = -o $(sudoers_uid) -g $(sudoers_gid)
++endif
+ sudoers_uid = @SUDOERS_UID@
+ sudoers_gid = @SUDOERS_GID@
+ sudoers_mode = @SUDOERS_MODE@
+@@ -302,18 +308,18 @@
+ $(DESTDIR)$(mandirsu) $(DESTDIR)$(mandirform)
+
+ install-binaries: $(PROGS)
+- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 4111 -s sudo $(DESTDIR)$(sudodir)/sudo
+- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0111 -s visudo $(DESTDIR)$(visudodir)/visudo
++ $(INSTALL) $(install_owncmd) -m 4555 -s sudo $(DESTDIR)$(sudodir)/sudo
++ $(INSTALL) $(install_owncmd) -m 0555 -s visudo $(DESTDIR)$(visudodir)/visudo
+
+ install-sudoers:
+ test -f $(DESTDIR)$(sudoersdir)/sudoers || \
+- $(INSTALL) -O $(sudoers_uid) -G $(sudoers_gid) -M $(sudoers_mode) \
++ $(INSTALL) $(sudoers_owncmd) -m $(sudoers_mode) \
+ $(srcdir)/sudoers $(DESTDIR)$(sudoersdir)/sudoers
+
+ install-man:
+- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
+- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
+- $(INSTALL) -O $(install_uid) -G $(install_gid) -M 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
++ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/sudo.$(mantype) $(DESTDIR)$(mandirsu)/sudo.$(mansectsu)
++ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/visudo.$(mantype) $(DESTDIR)$(mandirsu)/visudo.$(mansectsu)
++ $(INSTALL) $(install_owncmd) -m 0444 @mansrcdir@/sudoers.$(mantype) $(DESTDIR)$(mandirform)/sudoers.$(mansectform)
+ @MAN_POSTINSTALL@
+
+ check:
diff --git a/sudo/sudo-1.6.7p5/nostrip.patch b/sudo/sudo-1.6.7p5/nostrip.patch
index e69de29bb2..e82f4b67eb 100644
--- a/sudo/sudo-1.6.7p5/nostrip.patch
+++ b/sudo/sudo-1.6.7p5/nostrip.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- sudo-1.6.7p5/Makefile.in~nostrip.patch
++++ sudo-1.6.7p5/Makefile.in
+@@ -308,8 +308,8 @@
+ $(DESTDIR)$(mandirsu) $(DESTDIR)$(mandirform)
+
+ install-binaries: $(PROGS)
+- $(INSTALL) $(install_owncmd) -m 4555 -s sudo $(DESTDIR)$(sudodir)/sudo
+- $(INSTALL) $(install_owncmd) -m 0555 -s visudo $(DESTDIR)$(visudodir)/visudo
++ $(INSTALL) $(install_owncmd) -m 4555 sudo $(DESTDIR)$(sudodir)/sudo
++ $(INSTALL) $(install_owncmd) -m 0555 visudo $(DESTDIR)$(visudodir)/visudo
+
+ install-sudoers:
+ test -f $(DESTDIR)$(sudoersdir)/sudoers || \
+@@ -376,8 +376,6 @@
+ -e 's/@_mansectform@/$(mansectform)/g' $(srcdir)/Makefile.binary \
+ > $$tdir/Makefile ; \
+ )
+- strip sudo
+- strip visudo
+ ( cd tmp.`arch -l` && tar Ocf ../sudo-$(VERSION)-`arch -l`.tar sudo-$(VERSION) )
+ gzip --best sudo-$(VERSION)-`arch -l`.tar
+ rm -rf tmp.`arch -l`