summaryrefslogtreecommitdiff
path: root/snes232
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2004-10-10 17:42:28 +0000
committerPhil Blundell <philb@gnu.org>2004-10-10 17:42:28 +0000
commita9386051f49c6c21f02df2c9efbd337a051df6cd (patch)
tree1e7cdac91f396f27bfdd92414fca3568f36c9ca6 /snes232
parent2ec6127e9493ce4daaf2e9e72073f20354a5367c (diff)
add input_sync() calls
add kernel-module-serport to DEPENDS BKrev: 416974848jBsPTeyGzgvoCkd_UL43g
Diffstat (limited to 'snes232')
-rw-r--r--snes232/snes232-2.6.patch46
-rw-r--r--snes232/snes232_cvs.oe21
2 files changed, 67 insertions, 0 deletions
diff --git a/snes232/snes232-2.6.patch b/snes232/snes232-2.6.patch
index e69de29bb2..cfefe488ad 100644
--- a/snes232/snes232-2.6.patch
+++ b/snes232/snes232-2.6.patch
@@ -0,0 +1,46 @@
+--- snes232.c~snes232-2.6.patch 2002-11-18 00:18:44.000000000 +0000
++++ snes232.c 2004-10-10 01:15:10.000000000 +0100
+@@ -60,7 +60,7 @@
+ BTN_B, /* 15 */
+ };
+
+-static void snes232_interrupt(struct serio *serio, unsigned char data, unsigned int flags)
++static irqreturn_t snes232_interrupt(struct serio *serio, unsigned char data, unsigned int flags, struct pt_regs *regs)
+ {
+ struct snes232* snes232 = serio->private;
+ struct input_dev *dev = (data & 0x40) ? &snes232->dev[1] : &snes232->dev[0];
+@@ -85,6 +85,10 @@
+ input_report_key(dev, button_map[btn], down);
+ break;
+ }
++
++ input_sync(dev);
++
++ return IRQ_HANDLED;
+ }
+
+ /*
+@@ -133,10 +137,10 @@
+ snes232->dev[d].absbit[0] = BIT(ABS_X) | BIT(ABS_Y);
+
+ snes232->dev[d].name = snes232_name;
+- snes232->dev[d].idbus = BUS_RS232;
+- snes232->dev[d].idvendor = SERIO_SNES232;
+- snes232->dev[d].idproduct = 0x0001;
+- snes232->dev[d].idversion = 0x0100;
++ snes232->dev[d].id.bustype = BUS_RS232;
++ snes232->dev[d].id.vendor = SERIO_SNES232;
++ snes232->dev[d].id.product = 0x0001;
++ snes232->dev[d].id.version = 0x0100;
+
+ for (i = 0; i < 2; i++) {
+ snes232->dev[d].absmax[ABS_X+i] = 64;
+@@ -148,7 +152,7 @@
+
+ input_register_device(&snes232->dev[d]);
+
+- printk(KERN_INFO "input%d: %s on serio%d\n", snes232->dev[d].number, snes232_name, serio->number);
++ printk(KERN_INFO "%s: %s on %s\n", snes232->dev[d].name, snes232_name, serio->name);
+ }
+ }
+
diff --git a/snes232/snes232_cvs.oe b/snes232/snes232_cvs.oe
index e69de29bb2..911304d2dc 100644
--- a/snes232/snes232_cvs.oe
+++ b/snes232/snes232_cvs.oe
@@ -0,0 +1,21 @@
+PR = "r2"
+
+RDEPENDS = "kernel-module-serport"
+
+SRC_URI = "cvs://anoncvs:anoncvs@cvs.handhelds.org/cvs;module=gpe/games/snes232 \
+ file://snes232-2.6.patch;patch=1;pnum=0 \
+ file://Makefile-2.6"
+
+S = "${WORKDIR}/snes232"
+
+inherit module
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/Makefile-2.6 Makefile
+}
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/snes232
+ install snes232.ko ${D}/lib/modules/${KERNEL_VERSION}/snes232/
+}
+