summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-03-14 15:16:12 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-03-14 15:16:12 +0100
commite0a5c66df54995c23976707a157537a50d83fc4c (patch)
tree4e937d72772667c414e96dde0322d33d2c9d03f7 /recipes
parent6615eb994476c9c8e96dd8a00b76af90deb313a3 (diff)
linux-leviathan: depend on android-image-utils and prepare kernel image that can be booted via fastboot
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-leviathan_git.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes/linux/linux-leviathan_git.bb b/recipes/linux/linux-leviathan_git.bb
index 8ea4bfbb7b..a14fb21092 100644
--- a/recipes/linux/linux-leviathan_git.bb
+++ b/recipes/linux/linux-leviathan_git.bb
@@ -1,10 +1,10 @@
require linux.inc
+DEPENDS = "android-image-utils-native"
PV = "2.6.32+${PR}+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
COMPATIBLE_MACHINE = "htcdream"
-# CMDLINE is irrelevant on this hardware as we need a special userland tool to cook the image
CMDLINE = "console=tty0 no_console_suspend=1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M"
SRCREV_LAST_GOOD = "deabc32225429b3c0db44f7e62d95d0d2525290b"
@@ -15,3 +15,11 @@ SRC_URI = "\
file://defconfig \
"
S = "${WORKDIR}/git"
+
+do_deploy_append() {
+ touch -f empty
+ mkbootimg --kernel ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.bin \
+ --ramdisk empty \
+ --cmdline '"${CMDLINE}"' \
+ --output ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.fastboot
+}