summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-12-31 20:37:33 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-12-31 20:37:33 +0100
commit5cc693a438ef826c10f46337c100dfda785be66f (patch)
treea5562313c9262b16a71f3eef93598f1ef13bab29 /recipes
parent5c32410cd61bf46018d6af581984b25964962254 (diff)
parent1e7c93e555fb8c63a2e1baa334cf72f9c9dabfad (diff)
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/bluez/bluez4_4.59.bb16
-rw-r--r--recipes/gcc/gcc-cross-initial_svn.bb2
-rw-r--r--recipes/gcc/gcc-cross-intermediate_svn.bb2
-rw-r--r--recipes/gcc/gcc-cross-sdk_svn.bb2
-rw-r--r--recipes/gcc/gcc-cross_svn.bb2
-rw-r--r--recipes/gcc/gcc-svn.inc9
-rw-r--r--recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch30
-rw-r--r--recipes/gnome/libsoup-2.4_2.28.2.bb15
-rw-r--r--recipes/gnome/libsoup-2.4_2.29.3.bb15
-rw-r--r--recipes/gtk-webcore/midori_0.2.2.bb37
-rw-r--r--recipes/iptables/iptables.inc4
-rw-r--r--recipes/kexecboot/linux-kexecboot.inc11
-rw-r--r--recipes/libmpc/libmpc-native_0.8.1.bb (renamed from recipes/mpc/mpc-native_0.8.1.bb)2
-rw-r--r--recipes/libmpc/libmpc.inc (renamed from recipes/mpc/mpc.inc)0
-rw-r--r--recipes/libmpc/libmpc_0.8.1.bb (renamed from recipes/mpc/mpc_0.8.1.bb)2
-rw-r--r--recipes/linux/linux-2.6.31/qemux86/defconfig2
-rw-r--r--recipes/linux/linux_2.6.27.bb4
-rw-r--r--recipes/linux/linux_2.6.31.bb4
-rw-r--r--recipes/linux/linux_2.6.32.bb4
-rw-r--r--recipes/openmoko-3rdparty/neomis_svn.bb5
-rw-r--r--recipes/webkit/webkit-gtk/GNUmakefile.am78
-rw-r--r--recipes/webkit/webkit-gtk/configure.ac33
-rw-r--r--recipes/webkit/webkit-gtk_svn.bb6
-rw-r--r--recipes/xorg-app/viewres_1.0.2.bb5
-rw-r--r--recipes/xorg-app/xbiff_1.0.2.bb5
-rw-r--r--recipes/xorg-app/xcalc_1.0.3.bb4
-rw-r--r--recipes/xorg-app/xeyes_1.1.0.bb (renamed from recipes/xorg-app/xeyes_1.0.991.bb)0
-rw-r--r--recipes/xorg-driver/xf86-input-joystick_1.4.99.2.bb4
28 files changed, 231 insertions, 72 deletions
diff --git a/recipes/bluez/bluez4_4.59.bb b/recipes/bluez/bluez4_4.59.bb
new file mode 100644
index 0000000000..79e3005462
--- /dev/null
+++ b/recipes/bluez/bluez4_4.59.bb
@@ -0,0 +1,16 @@
+require bluez4.inc
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_angstrom = "1"
+DEFAULT_PREFERENCE_shr = "1"
+
+DEPENDS += "libsndfile1"
+
+PR = "${INC_PR}.0"
+
+# Not all distros have a recent enough udev
+BTUDEV = " --disable-udevrules"
+BTUDEV_angstrom = " --enable-udevrules"
+BTUDEV_shr = " --enable-udevrules"
+EXTRA_OECONF += "${BTUDEV}"
+
diff --git a/recipes/gcc/gcc-cross-initial_svn.bb b/recipes/gcc/gcc-cross-initial_svn.bb
index 0650a81ecf..8356dd1fac 100644
--- a/recipes/gcc/gcc-cross-initial_svn.bb
+++ b/recipes/gcc/gcc-cross-initial_svn.bb
@@ -1,7 +1,7 @@
require gcc-cross_${PV}.bb
require gcc-cross-initial.inc
-DEPENDS += "gmp-native mpfr-native mpc-native"
+DEPENDS += "gmp-native mpfr-native libmpc-native"
EXTRA_OECONF += " --disable-libmudflap \
--disable-libgomp \
diff --git a/recipes/gcc/gcc-cross-intermediate_svn.bb b/recipes/gcc/gcc-cross-intermediate_svn.bb
index 93cd35730b..b816c8b81c 100644
--- a/recipes/gcc/gcc-cross-intermediate_svn.bb
+++ b/recipes/gcc/gcc-cross-intermediate_svn.bb
@@ -1,7 +1,7 @@
require gcc-cross_${PV}.bb
require gcc-cross-intermediate.inc
-DEPENDS += "mpc-native gmp-native mpfr-native"
+DEPENDS += "libmpc-native gmp-native mpfr-native"
EXTRA_OECONF += " --disable-libmudflap \
--disable-libgomp \
diff --git a/recipes/gcc/gcc-cross-sdk_svn.bb b/recipes/gcc/gcc-cross-sdk_svn.bb
index 752266be5f..48d8a0d1ed 100644
--- a/recipes/gcc/gcc-cross-sdk_svn.bb
+++ b/recipes/gcc/gcc-cross-sdk_svn.bb
@@ -7,7 +7,7 @@ require gcc-cross-sdk.inc
require gcc-configure-sdk.inc
require gcc-package-sdk.inc
-DEPENDS += "mpc-native gmp-native mpfr-native"
+DEPENDS += "libmpc-native gmp-native mpfr-native"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
--disable-libgomp --disable-libmudflap \
diff --git a/recipes/gcc/gcc-cross_svn.bb b/recipes/gcc/gcc-cross_svn.bb
index c8e75d1881..2d3c1368dc 100644
--- a/recipes/gcc/gcc-cross_svn.bb
+++ b/recipes/gcc/gcc-cross_svn.bb
@@ -4,7 +4,7 @@ require gcc-cross4.inc
require gcc-configure-cross.inc
require gcc-package-cross.inc
-DEPENDS += "mpc-native"
+DEPENDS += "libmpc-native"
SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
diff --git a/recipes/gcc/gcc-svn.inc b/recipes/gcc/gcc-svn.inc
index 0198a8ddd9..6134aa2eaf 100644
--- a/recipes/gcc/gcc-svn.inc
+++ b/recipes/gcc/gcc-svn.inc
@@ -1,15 +1,14 @@
DEFAULT_PREFERENCE = "-999"
ARM_INSTRUCTION_SET = "arm"
-SRCREV="155514"
+SRCREV = "155514"
require gcc-common.inc
-DEPENDS = "mpfr gmp mpc"
+DEPENDS = "mpfr gmp libmpc"
-GCC_BASE ?= "4.5"
-PV = "${GCC_BASE}+svnr${SRCREV}"
-PR = "r0"
+BINV = "4.5.0"
+PV = "4.5+svnr${SRCPV}"
FILESPATHPKG .= ":gcc-svn"
diff --git a/recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch b/recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch
new file mode 100644
index 0000000000..348c77006f
--- /dev/null
+++ b/recipes/gcc/gcc-svn/fortran-cross-compile-hack.patch
@@ -0,0 +1,30 @@
+* Fortran would have searched for arm-angstrom-gnueabi-gfortran but would have used
+ used gfortan. For gcc_4.2.2.bb we want to use the gfortran compiler from our cross
+ directory.
+
+Index: gcc-4.5+svnr155514/libgfortran/configure
+===================================================================
+--- gcc-4.5+svnr155514.orig/libgfortran/configure 2009-12-29 22:02:01.000000000 -0800
++++ gcc-4.5+svnr155514/libgfortran/configure 2009-12-30 08:12:40.889091657 -0800
+@@ -11655,7 +11655,7 @@ CC="$lt_save_CC"
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ ac_ext=${ac_fc_srcext-f}
+ ac_compile='$FC -c $FCFLAGS $ac_fcflags_srcext conftest.$ac_ext >&5'
+ ac_link='$FC -o conftest$ac_exeext $FCFLAGS $LDFLAGS $ac_fcflags_srcext conftest.$ac_ext $LIBS >&5'
+Index: gcc-4.5+svnr155514/libgfortran/configure.ac
+===================================================================
+--- gcc-4.5+svnr155514.orig/libgfortran/configure.ac 2009-12-29 22:02:01.000000000 -0800
++++ gcc-4.5+svnr155514/libgfortran/configure.ac 2009-12-30 08:12:13.453094218 -0800
+@@ -187,7 +187,7 @@ AC_SUBST(enable_static)
+
+ # We need gfortran to compile parts of the library
+ #AC_PROG_FC(gfortran)
+-FC="$GFORTRAN"
++#FC="$GFORTRAN"
+ AC_PROG_FC(gfortran)
+
+ # extra LD Flags which are required for targets
diff --git a/recipes/gnome/libsoup-2.4_2.28.2.bb b/recipes/gnome/libsoup-2.4_2.28.2.bb
new file mode 100644
index 0000000000..a13106e0b5
--- /dev/null
+++ b/recipes/gnome/libsoup-2.4_2.28.2.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "An HTTP library implementation in C"
+SECTION = "x11/gnome/libs"
+LICENSE = "GPL"
+DEPENDS = "libproxy glib-2.0 gnutls libxml2 sqlite3 gnome-keyring"
+
+inherit gnome
+
+SRC_URI = "${GNOME_MIRROR}/libsoup/${@gnome_verdir("${PV}")}/libsoup-${PV}.tar.bz2"
+S = "${WORKDIR}/libsoup-${PV}"
+
+PACKAGES =+ "libsoup-gnome"
+FILES_libsoup-gnome = "${libdir}/libsoup-gnome*.so.*"
+FILES_${PN} = "${libdir}/libsoup-2*.so.*"
+FILES_${PN}-dev = "${includedir}/ ${libdir}/"
+FILES_${PN}-doc = "${datadir}/"
diff --git a/recipes/gnome/libsoup-2.4_2.29.3.bb b/recipes/gnome/libsoup-2.4_2.29.3.bb
new file mode 100644
index 0000000000..a13106e0b5
--- /dev/null
+++ b/recipes/gnome/libsoup-2.4_2.29.3.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "An HTTP library implementation in C"
+SECTION = "x11/gnome/libs"
+LICENSE = "GPL"
+DEPENDS = "libproxy glib-2.0 gnutls libxml2 sqlite3 gnome-keyring"
+
+inherit gnome
+
+SRC_URI = "${GNOME_MIRROR}/libsoup/${@gnome_verdir("${PV}")}/libsoup-${PV}.tar.bz2"
+S = "${WORKDIR}/libsoup-${PV}"
+
+PACKAGES =+ "libsoup-gnome"
+FILES_libsoup-gnome = "${libdir}/libsoup-gnome*.so.*"
+FILES_${PN} = "${libdir}/libsoup-2*.so.*"
+FILES_${PN}-dev = "${includedir}/ ${libdir}/"
+FILES_${PN}-doc = "${datadir}/"
diff --git a/recipes/gtk-webcore/midori_0.2.2.bb b/recipes/gtk-webcore/midori_0.2.2.bb
new file mode 100644
index 0000000000..d17e234e51
--- /dev/null
+++ b/recipes/gtk-webcore/midori_0.2.2.bb
@@ -0,0 +1,37 @@
+require midori.inc
+
+DEPENDS += "python-native python-docutils-native"
+
+SRC_URI = "http://archive.xfce.org/src/apps/midori/0.2/midori-${PV}.tar.bz2 \
+ file://waf"
+
+SRC_URI_append_shr = " file://config \
+ "
+
+do_configure() {
+ cp -f ${WORKDIR}/waf ${S}/
+ sed -i -e 's:, shell=False::g' wscript
+ ./configure \
+ --prefix=${prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF}
+
+ sed -i /LINK_CC/d ./_build_/c4che/default.cache.py
+ echo "LINK_CC = '${CXX}'" >> ./_build_/c4che/default.cache.py
+}
+
+do_install_append_shr() {
+ install -d ${D}${sysconfdir}/xdg/midori
+ install -m 0644 ${WORKDIR}/config ${D}${sysconfdir}/xdg/midori
+}
+
diff --git a/recipes/iptables/iptables.inc b/recipes/iptables/iptables.inc
index fd16f97b0a..698c25975c 100644
--- a/recipes/iptables/iptables.inc
+++ b/recipes/iptables/iptables.inc
@@ -6,7 +6,7 @@ LICENSE = "GPL"
SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2"
S = "${WORKDIR}/iptables-${PV}"
-INC_PR = "r5"
+INC_PR = "r6"
PARALLEL_MAKE = ""
@@ -26,7 +26,7 @@ inherit autotools
PACKAGES =+ "${PN}-utils"
FILES_${PN}-utils = "${sbindir}/iptables-save ${sbindir}/iptables-restore"
FILES_${PN}-doc += "${mandir}"
-FILES_${PN}-dbg += "${libexecdir}/xtables"
+FILES_${PN}-dbg += "${libexecdir}/xtables/.debug/*"
RRECOMMENDS = "\
kernel-module-ip-tables \
diff --git a/recipes/kexecboot/linux-kexecboot.inc b/recipes/kexecboot/linux-kexecboot.inc
index 4b2bb1d00a..0d5f2bb2ac 100644
--- a/recipes/kexecboot/linux-kexecboot.inc
+++ b/recipes/kexecboot/linux-kexecboot.inc
@@ -1,5 +1,5 @@
# We set PR here, since a change in the kexecboot recipe will need to get picked up by *all* the kernels:
-PR = "r15"
+PR = "r16"
SRC_URI = "file://defconfig"
@@ -31,12 +31,18 @@ TKSRC = "http://www.informatik.hu-berlin.de/~tkunze/zaurus/patches"
KERNEL_IMAGE_BASE_NAME = "${KERNEL_IMAGETYPE}-kexecboot-${PV}-${PR}-${MACHINE}"
KERNEL_IMAGE_SYMLINK_NAME = "${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}"
+#
+# default lzma compressor for kernels >= 2.6.30
+INITRAMFS_COMPRESSION = '${@base_version_less_or_equal("PV", "2.6.30", "", "CONFIG_INITRAMFS_COMPRESSION_LZMA=y", d)}'
+INITRAMFS_COMPRESSION_SUFFIX = '${@base_version_less_or_equal("PV", "2.6.30", "gz", "lzma", d)}'
+
do_configure[depends] += "${INITRAMFS_IMAGE}:do_rootfs"
do_configure_append() {
sed -i -e /CONFIG_BLK_DEV_INITRD/d \
-e /CONFIG_KEXEC/d \
-e /CONFIG_INITRAMFS_SOURCE/d \
+ -e /CONFIG_INITRAMFS_COMPRESSION/d \
-e /=m/d \
-e /CONFIG_MODULES/d \
-e /CONFIG_DEBUG_ERRORS/d \
@@ -50,7 +56,8 @@ sed -i -e /CONFIG_CMDLINE/s/debug/loglevel=3/1 ${S}/.config
echo 'CONFIG_BLK_DEV_INITRD=y
CONFIG_KEXEC=y
-CONFIG_INITRAMFS_SOURCE="initramfs.cpio.gz"
+${INITRAMFS_COMPRESSION}
+CONFIG_INITRAMFS_SOURCE="initramfs.cpio.${INITRAMFS_COMPRESSION_SUFFIX}"
CONFIG_MODULES=n' >> ${S}/.config
yes '' | oe_runmake oldconfig
diff --git a/recipes/mpc/mpc-native_0.8.1.bb b/recipes/libmpc/libmpc-native_0.8.1.bb
index 8dba0b7fc4..a0837a6fbc 100644
--- a/recipes/mpc/mpc-native_0.8.1.bb
+++ b/recipes/libmpc/libmpc-native_0.8.1.bb
@@ -1,3 +1,3 @@
-require mpc_${PV}.bb
+require libmpc_${PV}.bb
inherit native
DEPENDS = "mpfr-native gmp-native"
diff --git a/recipes/mpc/mpc.inc b/recipes/libmpc/libmpc.inc
index 6e18e588be..6e18e588be 100644
--- a/recipes/mpc/mpc.inc
+++ b/recipes/libmpc/libmpc.inc
diff --git a/recipes/mpc/mpc_0.8.1.bb b/recipes/libmpc/libmpc_0.8.1.bb
index b62c08673e..670db173f4 100644
--- a/recipes/mpc/mpc_0.8.1.bb
+++ b/recipes/libmpc/libmpc_0.8.1.bb
@@ -1,4 +1,4 @@
-require mpc.inc
+require libmpc.inc
DEPENDS = "gmp mpfr"
diff --git a/recipes/linux/linux-2.6.31/qemux86/defconfig b/recipes/linux/linux-2.6.31/qemux86/defconfig
index 3137af0c5e..395258c430 100644
--- a/recipes/linux/linux-2.6.31/qemux86/defconfig
+++ b/recipes/linux/linux-2.6.31/qemux86/defconfig
@@ -1149,7 +1149,7 @@ CONFIG_E100=m
CONFIG_FEALNX=m
CONFIG_NATSEMI=m
CONFIG_NE2K_PCI=y
-# CONFIG_8139CP is not set
+CONFIG_8139CP=y
CONFIG_8139TOO=y
CONFIG_8139TOO_PIO=y
# CONFIG_8139TOO_TUNE_TWISTER is not set
diff --git a/recipes/linux/linux_2.6.27.bb b/recipes/linux/linux_2.6.27.bb
index 9e8d6a32e0..02f32dc46c 100644
--- a/recipes/linux/linux_2.6.27.bb
+++ b/recipes/linux/linux_2.6.27.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r11"
+PR = "r12"
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
@@ -9,7 +9,7 @@ DEFAULT_PREFERENCE_progear = "1"
DEFAULT_PREFERENCE_simpad = "-1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.41.bz2;patch=1 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.42.bz2;patch=1 \
file://defconfig "
SRC_URI_append_boc01 = "\
diff --git a/recipes/linux/linux_2.6.31.bb b/recipes/linux/linux_2.6.31.bb
index dcce779ebd..f5dd79b6c9 100644
--- a/recipes/linux/linux_2.6.31.bb
+++ b/recipes/linux/linux_2.6.31.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r8"
+PR = "r9"
S = "${WORKDIR}/linux-${PV}"
@@ -16,7 +16,7 @@ DEFAULT_PREFERENCE_ben-nanonote = "1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.8.bz2;patch=1 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.9.bz2;patch=1 \
file://defconfig"
SRC_URI += "file://0001-Squashfs-move-zlib-decompression-wrapper-code-into.patch;patch=1 \
diff --git a/recipes/linux/linux_2.6.32.bb b/recipes/linux/linux_2.6.32.bb
index be3d8ad7c6..a7861af17c 100644
--- a/recipes/linux/linux_2.6.32.bb
+++ b/recipes/linux/linux_2.6.32.bb
@@ -1,6 +1,6 @@
require linux.inc
-PR = "r2"
+PR = "r3"
S = "${WORKDIR}/linux-${PV}"
@@ -15,7 +15,7 @@ DEFAULT_PREFERENCE_spitz = "-1"
DEFAULT_PREFERENCE_tosa = "-1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
- ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.1.bz2;patch=1 \
+ ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${PV}.2.bz2;patch=1 \
file://defconfig"
SRC_URI[kernel.md5sum] = "260551284ac224c3a43c4adac7df4879"
diff --git a/recipes/openmoko-3rdparty/neomis_svn.bb b/recipes/openmoko-3rdparty/neomis_svn.bb
index 2b6075b787..1ea20a2d58 100644
--- a/recipes/openmoko-3rdparty/neomis_svn.bb
+++ b/recipes/openmoko-3rdparty/neomis_svn.bb
@@ -7,6 +7,7 @@ PRIORITY = "optional"
DEPENDS = "python-native"
PV = "1.1.0+svnr${SRCPV}"
+PR = "r1"
S = "${WORKDIR}/trunk"
@@ -16,6 +17,10 @@ SRC_URI = "svn://neomis.googlecode.com/svn;module=trunk;proto=http"
inherit distutils
+do_configure_prepend_shr() {
+ sed -e 's,^Exec=,Exec=/usr/bin/fsoraw -r Display ,g' -i ${S}/data/neomis.desktop
+}
+
FILES_${PN} += "${datadir}/neomis ${datadir}/applications/neomis.desktop ${datadir}/pixmaps"
RDEPENDS += "python-audio python-pyalsaaudio python-elementary"
diff --git a/recipes/webkit/webkit-gtk/GNUmakefile.am b/recipes/webkit/webkit-gtk/GNUmakefile.am
index 89260ad3a9..3a0e398aa4 100644
--- a/recipes/webkit/webkit-gtk/GNUmakefile.am
+++ b/recipes/webkit/webkit-gtk/GNUmakefile.am
@@ -29,6 +29,10 @@
srcdir = @srcdir@
VPATH = @srcdir@
+DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-introspection \
+ --enable-gtk-doc
+
# Directory for autogenerated sources
GENSOURCES := $(top_builddir)/DerivedSources
GENPROGRAMS := $(top_builddir)/Programs
@@ -74,6 +78,11 @@ global_cflags :=
global_cxxflags :=
corekit_cflags :=
corekit_cppflags :=
+JSCORE_GIRSOURCES :=
+WEBKIT_GIRSOURCES :=
+typelibsdir :=
+typelibs_DATA :=
+EXTRA_DIST :=
BUILT_SOURCES :=
CLEANFILES :=
DISTCLEANFILES :=
@@ -152,6 +161,7 @@ javascriptcore_cppflags += \
-I$(srcdir)/JavaScriptCore/ForwardingHeaders \
-I$(srcdir)/JavaScriptCore/parser \
-I$(srcdir)/JavaScriptCore/wtf \
+ -I$(srcdir)/JavaScriptCore/wtf/gtk \
-I$(top_builddir)/DerivedSources
nodist_EXTRA_libJavaScriptCore_la_SOURCES = \
@@ -413,29 +423,16 @@ webkitgtk_cleanfiles += \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = WebKit/gtk/webkit-1.0.pc
-# Files that will be distributed
-EXTRA_DIST = \
- $(srcdir)/gtk-doc.make \
- WebKit/LICENSE \
- $(javascriptcore_dist) \
- $(webcore_dist) \
- $(srcdir)/autotools/symbols.filter \
- $(srcdir)/WebKit/gtk/ChangeLog \
- $(srcdir)/WebKit/gtk/NEWS \
- $(srcdir)/WebKit/gtk/webkitmarshal.list \
- $(srcdir)/WebKit/gtk/docs/GNUmakefile.* \
- $(srcdir)/WebKit/gtk/docs/webkitenvironment.xml \
- $(srcdir)/WebKit/gtk/docs/webkitgtk-docs.sgml \
- $(srcdir)/WebKit/gtk/docs/webkitgtk-sections.txt \
- $(srcdir)/WebKit/gtk/docs/version.xml.in \
- $(srcdir)/WebKit/gtk/po/* \
- $(srcdir)/WebKit/gtk/resources/*
-
if ENABLE_INTROSPECTION
-JSCORE_GIRSOURCES = $(srcdir)/WebKit/gtk/JSCore-1.0.gir # JSCore-1.0.gir is handwritten
-WEBKIT_GIRSOURCES = WebKit-1.0.gir
+JSCORE_GIRSOURCES += JSCore-1.0.gir
+WEBKIT_GIRSOURCES += WebKit-1.0.gir
+
+# JSCore-1.0.gir is handwritten - this is a hack to make the typelib
+# generation work during make dist
+JSCore-1.0.gir: $(srcdir)/WebKit/gtk/JSCore-1.0.gir
+ cp $(srcdir)/WebKit/gtk/JSCore-1.0.gir $(builddir)/
-$(WEBKIT_GIRSOURCES): $(JSCORE_GIRSOURCES) $(G_IR_SCANNER)
+$(WEBKIT_GIRSOURCES): $(JSCORE_GIRSOURCES) $(G_IR_SCANNER) libwebkit-1.0.la
$(AM_V_GEN)$(G_IR_SCANNER) -v --namespace WebKit --nsversion=1.0 \
--include=GObject-2.0 \
--include=Gtk-2.0 \
@@ -446,6 +443,7 @@ $(WEBKIT_GIRSOURCES): $(JSCORE_GIRSOURCES) $(G_IR_SCANNER)
--pkg gobject-2.0 \
--pkg gtk+-2.0 \
--output $@ \
+ --add-include-path $(top_srcdir)/WebKit/gtk \
-I$(top_srcdir)/WebKit/gtk \
-I$(top_builddir)/WebKit/gtk \
-I$(top_srcdir)/JavaScriptCore/ForwardingHeaders \
@@ -455,14 +453,14 @@ $(WEBKIT_GIRSOURCES): $(JSCORE_GIRSOURCES) $(G_IR_SCANNER)
girdir = $(GIRDIR)
gir_DATA = $(WEBKIT_GIRSOURCES) $(JSCORE_GIRSOURCES)
-typelibsdir = $(GIRTYPELIBDIR)
-typelibs_DATA = $(JSCORE_GIRSOURCES:.gir=.typelib) $(WEBKIT_GIRSOURCES:.gir=.typelib)
+typelibsdir += $(GIRTYPELIBDIR)
+typelibs_DATA += $(JSCORE_GIRSOURCES:.gir=.typelib) $(WEBKIT_GIRSOURCES:.gir=.typelib)
%.typelib: %.gir $(G_IR_COMPILER)
- $(AM_V_GEN)$(G_IR_COMPILER) $< -o $@
+ $(AM_V_GEN)$(G_IR_COMPILER) --includedir $(top_srcdir)/WebKit/gtk $< -o $@
EXTRA_DIST += $(JSCORE_GIRSOURCES)
-CLEANFILES += $(WEBKIT_GIRSOURCES) $(typelibs_DATA)
+CLEANFILES += $(JSCORE_GIRSOURCES) $(WEBKIT_GIRSOURCES) $(typelibs_DATA)
endif
@@ -528,6 +526,24 @@ DerivedSources/webkitenumtypes.cpp: $(webkitgtk_h_api) GNUmakefile
&& cp xgen-gtc $@ \
&& rm -f xgen-gtc
+# Files that will be distributed
+EXTRA_DIST += \
+ $(srcdir)/gtk-doc.make \
+ WebKit/LICENSE \
+ $(javascriptcore_dist) \
+ $(webcore_dist) \
+ $(srcdir)/autotools/symbols.filter \
+ $(srcdir)/WebKit/gtk/ChangeLog \
+ $(srcdir)/WebKit/gtk/NEWS \
+ $(srcdir)/WebKit/gtk/webkitmarshal.list \
+ $(srcdir)/WebKit/gtk/docs/GNUmakefile.* \
+ $(srcdir)/WebKit/gtk/docs/webkitenvironment.xml \
+ $(srcdir)/WebKit/gtk/docs/webkitgtk-docs.sgml \
+ $(srcdir)/WebKit/gtk/docs/webkitgtk-sections.txt \
+ $(srcdir)/WebKit/gtk/docs/version.xml.in \
+ $(srcdir)/WebKit/gtk/po/* \
+ $(srcdir)/WebKit/gtk/resources/*
+
# extra resource files
resourcesdir = ${datadir}/webkit-1.0/resources
dist_resources_DATA = \
@@ -566,6 +582,7 @@ webkit_tests_ldflags = \
TEST_PROGS += Programs/unittests/testhttpbackend \
Programs/unittests/testloading \
+ Programs/unittests/testmimehandling \
Programs/unittests/testnetworkrequest \
Programs/unittests/testnetworkresponse \
Programs/unittests/testwebframe \
@@ -578,6 +595,7 @@ TEST_PROGS += Programs/unittests/testhttpbackend \
Programs/unittests/testwebsettings \
Programs/unittests/testwebresource \
Programs/unittests/testwebdatasource \
+ Programs/unittests/testwebview \
Programs/unittests/testkeyevents
# Add additional tests here
@@ -591,6 +609,11 @@ Programs_unittests_testloading_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testloading_LDADD = $(webkit_tests_ldadd)
Programs_unittests_testloading_LDFLAGS = $(webkit_tests_ldflags)
+Programs_unittests_testmimehandling_SOURCES = WebKit/gtk/tests/testmimehandling.c
+Programs_unittests_testmimehandling_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testmimehandling_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testmimehandling_LDFLAGS = $(webkit_tests_ldflags)
+
Programs_unittests_testnetworkrequest_SOURCES = WebKit/gtk/tests/testnetworkrequest.c
Programs_unittests_testnetworkrequest_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testnetworkrequest_LDADD = $(webkit_tests_ldadd)
@@ -644,6 +667,11 @@ Programs_unittests_testwebdatasource_SOURCES = WebKit/gtk/tests/testwebdatasourc
Programs_unittests_testwebdatasource_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testwebdatasource_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testwebview_SOURCES = WebKit/gtk/tests/testwebview.c
+Programs_unittests_testwebview_CFLAGS = $(webkit_tests_cflags)
+Programs_unittests_testwebview_LDADD = $(webkit_tests_ldadd)
+Programs_unittests_testwebview_LDFLAGS = $(webkit_tests_ldflags)
+
Programs_unittests_testhittestresult_SOURCES = WebKit/gtk/tests/testhittestresult.c
Programs_unittests_testhittestresult_CFLAGS = $(webkit_tests_cflags)
Programs_unittests_testhittestresult_LDADD = $(webkit_tests_ldadd)
diff --git a/recipes/webkit/webkit-gtk/configure.ac b/recipes/webkit/webkit-gtk/configure.ac
index b4230fb7fa..d2877c0834 100644
--- a/recipes/webkit/webkit-gtk/configure.ac
+++ b/recipes/webkit/webkit-gtk/configure.ac
@@ -2,7 +2,7 @@ AC_PREREQ(2.59)
m4_define([webkit_major_version], [1])
m4_define([webkit_minor_version], [1])
-m4_define([webkit_micro_version], [16])
+m4_define([webkit_micro_version], [18])
# This is the version we'll be using as part of our User-Agent string
# e.g., AppleWebKit/$(webkit_user_agent_version) ...
@@ -35,7 +35,7 @@ AC_CONFIG_SRCDIR([WebCore/config.h])
dnl # Libtool library version, not to confuse with API version
dnl # see http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html#Libtool-versioning
-LIBWEBKITGTK_VERSION=14:0:12
+LIBWEBKITGTK_VERSION=15:0:13
AC_SUBST([LIBWEBKITGTK_VERSION])
AM_INIT_AUTOMAKE([foreign subdir-objects tar-ustar])
@@ -191,7 +191,7 @@ fi
# minimum base dependencies
LIBSOUP_REQUIRED_VERSION=2.27.91
-CAIRO_REQUIRED_VERSION=1.2
+CAIRO_REQUIRED_VERSION=1.6
FONTCONFIG_REQUIRED_VERSION=2.4
FREETYPE2_REQUIRED_VERSION=9.0
LIBXML_REQUIRED_VERSION=2.6
@@ -371,14 +371,6 @@ AC_ARG_ENABLE(datalist,
[],[enable_datalist="yes"])
AC_MSG_RESULT([$enable_datalist])
-# check whether to enable HTML5 ruby support
-AC_MSG_CHECKING([whether to enable HTML5 ruby support])
-AC_ARG_ENABLE(ruby,
- AC_HELP_STRING([--enable-ruby],
- [enable HTML5 ruby support [default=yes]]),
- [],[enable_ruby="yes"])
-AC_MSG_RESULT([$enable_ruby])
-
# check whether to enable HTML5 audio/video support
AC_MSG_CHECKING([whether to enable HTML5 video support])
AC_ARG_ENABLE(video,
@@ -472,8 +464,8 @@ AC_MSG_RESULT([$enable_svg_animation])
AC_MSG_CHECKING([whether to enable support for filters])
AC_ARG_ENABLE(filters,
AC_HELP_STRING([--enable-filters],
- [enable support for filters (experimental) [default=no]]),
- [],[enable_filters="no"])
+ [enable support for filters (experimental) [default=yes]]),
+ [],[enable_filters="yes"])
AC_MSG_RESULT([$enable_filters])
# check whether to enable support for SVG fonts
@@ -596,8 +588,8 @@ if test "$enable_introspection" = "yes"; then
G_IR_SCANNER="$($PKG_CONFIG --variable=g_ir_scanner gobject-introspection-1.0)"
G_IR_COMPILER="$($PKG_CONFIG --variable=g_ir_compiler gobject-introspection-1.0)"
G_IR_GENERATE="$($PKG_CONFIG --variable=g_ir_generate gobject-introspection-1.0)"
- GIRDIR="$($PKG_CONFIG --variable=girdir gobject-introspection-1.0)"
- GIRTYPELIBDIR="$($PKG_CONFIG --variable=typelibdir gobject-introspection-1.0)"
+ GIRDIR="$($PKG_CONFIG --define-variable=prefix=$prefix --variable=girdir gobject-introspection-1.0)"
+ GIRTYPELIBDIR="$($PKG_CONFIG --define-variable=prefix=$prefix --variable=typelibdir gobject-introspection-1.0)"
AC_DEFINE([ENABLE_INTROSPECTION],[1],[Define to enable GObject introspection support])
fi
@@ -643,6 +635,15 @@ PKG_CHECK_MODULES([LIBSOUP],
AC_SUBST([LIBSOUP_CFLAGS])
AC_SUBST([LIBSOUP_LIBS])
+# check if we can use libSoup 2.29.3 features
+PKG_CHECK_MODULES([LIBSOUP_2_29_3],
+ [libsoup-2.4 >= 2.29.3],
+ [have_libsoup_2_29_3=yes],
+ [have_libsoup_2_29_3=no])
+if test "$have_libsoup_2_29_3" = "yes"; then
+ AC_DEFINE([HAVE_LIBSOUP_2_29_3], 1, [Whether libSoup 2.29.3 features are available])
+fi
+
# check if FreeType/FontConfig are available
if test "$with_font_backend" = "freetype"; then
if test "$with_target" = "directfb"; then
@@ -756,7 +757,6 @@ AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"])
AM_CONDITIONAL([ENABLE_MATHML], [test "$enable_mathml" = "yes"])
-AM_CONDITIONAL([ENABLE_RUBY],[test "$enable_ruby" = "yes"])
AM_CONDITIONAL([ENABLE_VIDEO],[test "$enable_video" = "yes"])
AM_CONDITIONAL([ENABLE_NOTIFICATIONS],[test "$enable_notifications" = "yes"])
AM_CONDITIONAL([ENABLE_ORIENTATION_EVENTS],[test "$enable_orientation_events" = "yes"])
@@ -812,7 +812,6 @@ Features:
HTML5 channel messaging support : $enable_channel_messaging
HTML5 client-side session and persistent storage support : $enable_dom_storage
HTML5 client-side database storage support : $enable_database
- HTML5 ruby support : $enable_ruby
HTML5 server-sent events support : $enable_eventsource
HTML5 video element support : $enable_video
Icon database support : $enable_icon_database
diff --git a/recipes/webkit/webkit-gtk_svn.bb b/recipes/webkit/webkit-gtk_svn.bb
index 96f47f1663..a2d3be83b1 100644
--- a/recipes/webkit/webkit-gtk_svn.bb
+++ b/recipes/webkit/webkit-gtk_svn.bb
@@ -3,8 +3,8 @@ DEPENDS = "enchant gtk-doc-native gtk-doc gnome-keyring libsoup-2.4 curl icu lib
SRCREV_FORMAT = "webcore-rwebkit"
-SRCREV = "50081"
-PV = "1.1.16+svnr${SRCPV}"
+SRCREV = "52207"
+PV = "1.1.18+svnr${SRCPV}"
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -32,9 +32,7 @@ EXTRA_OECONF = "\
--enable-debug=no \
--enable-svg \
--enable-icon-database=yes \
- --with-http-backend=soup \
# --with-unicode-backend=glib \
- --with-libsoup-gnome=yes \
"
EXTRA_AUTORECONF = " -I autotools "
diff --git a/recipes/xorg-app/viewres_1.0.2.bb b/recipes/xorg-app/viewres_1.0.2.bb
new file mode 100644
index 0000000000..f884467096
--- /dev/null
+++ b/recipes/xorg-app/viewres_1.0.2.bb
@@ -0,0 +1,5 @@
+require xorg-app-common.inc
+PE = "1"
+
+DEPENDS += " libxt"
+
diff --git a/recipes/xorg-app/xbiff_1.0.2.bb b/recipes/xorg-app/xbiff_1.0.2.bb
new file mode 100644
index 0000000000..e3264d7684
--- /dev/null
+++ b/recipes/xorg-app/xbiff_1.0.2.bb
@@ -0,0 +1,5 @@
+require xorg-app-common.inc
+PE = "1"
+
+DEPENDS += " libxaw xbitmaps libxext"
+
diff --git a/recipes/xorg-app/xcalc_1.0.3.bb b/recipes/xorg-app/xcalc_1.0.3.bb
new file mode 100644
index 0000000000..54b7549f5c
--- /dev/null
+++ b/recipes/xorg-app/xcalc_1.0.3.bb
@@ -0,0 +1,4 @@
+require xorg-app-common.inc
+DESCRIPTION = "scientific calculator for X"
+DEPENDS += " libxaw libxt"
+PE = "1"
diff --git a/recipes/xorg-app/xeyes_1.0.991.bb b/recipes/xorg-app/xeyes_1.1.0.bb
index 07ce0724fa..07ce0724fa 100644
--- a/recipes/xorg-app/xeyes_1.0.991.bb
+++ b/recipes/xorg-app/xeyes_1.1.0.bb
diff --git a/recipes/xorg-driver/xf86-input-joystick_1.4.99.2.bb b/recipes/xorg-driver/xf86-input-joystick_1.4.99.2.bb
deleted file mode 100644
index a53297fd8a..0000000000
--- a/recipes/xorg-driver/xf86-input-joystick_1.4.99.2.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-require xorg-driver-input.inc
-
-DESCRIPTION = "X.Org X server -- joystick input driver"
-PE = "1"