summaryrefslogtreecommitdiff
path: root/recipes
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-26 12:19:54 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-10-26 12:19:54 +0100
commit4882a87cc59eb6c984a4b95507c4f01fed2f6079 (patch)
treed4e13c32297caacf790ea68ba97d56977dd71716 /recipes
parent8afa9e311db005dc86f23fb0fa6c89b57f7bf474 (diff)
parentdba8dec4093dc68610b762c8c7ac4e38c31cc8f9 (diff)
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/curl/curl-common.inc10
-rw-r--r--recipes/curl/curl-native_7.18.2.bb2
-rw-r--r--recipes/curl/curl-native_7.19.6.bb12
-rw-r--r--recipes/curl/curl-sdk_7.18.2.bb2
-rw-r--r--recipes/curl/curl_7.18.2.bb2
-rw-r--r--recipes/curl/curl_7.19.5.bb2
-rw-r--r--recipes/curl/curl_7.19.6.bb5
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.9.bb23
8 files changed, 52 insertions, 6 deletions
diff --git a/recipes/curl/curl-common.inc b/recipes/curl/curl-common.inc
index ce4f5f2a8e..29af47ee8d 100644
--- a/recipes/curl/curl-common.inc
+++ b/recipes/curl/curl-common.inc
@@ -6,8 +6,10 @@ SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://pkgconfig_fix.patch;patch=1"
S = "${WORKDIR}/curl-${PV}"
+INC_PR = "r2"
+
CURL_FEATURES ?= "zlib,gnutls,cookies,crypto-auth,dict,file,ftp,http,telnet,tftp"
-# other allowed features: ipv6, ares
+# other allowed features: ipv6, ares, openssl
inherit autotools pkgconfig binconfig
@@ -15,7 +17,6 @@ EXTRA_OECONF = " \
--without-libssh2 \
--with-random=/dev/urandom \
--without-libidn \
- --without-ssl \
"
python __anonymous() {
@@ -37,6 +38,11 @@ python __anonymous() {
deps.append("gnutls")
else:
oeconf += " --without-gnutls"
+ if 'openssl' in f:
+ oeconf += " --with-ssl=${STAGING_LIBDIR}/../"
+ deps.append("openssl")
+ else:
+ oeconf += " --without-ssl"
if 'ares' in f:
oeconf += " --enable-ares"
deps.append("c-ares")
diff --git a/recipes/curl/curl-native_7.18.2.bb b/recipes/curl/curl-native_7.18.2.bb
index c95591b70b..d395021512 100644
--- a/recipes/curl/curl-native_7.18.2.bb
+++ b/recipes/curl/curl-native_7.18.2.bb
@@ -1,7 +1,7 @@
require curl-common.inc
inherit native
DEPENDS = "zlib-native"
-PR = "r1"
+PR = "${INC_PR}.1"
do_stage () {
autotools_stage_all
diff --git a/recipes/curl/curl-native_7.19.6.bb b/recipes/curl/curl-native_7.19.6.bb
new file mode 100644
index 0000000000..d395021512
--- /dev/null
+++ b/recipes/curl/curl-native_7.19.6.bb
@@ -0,0 +1,12 @@
+require curl-common.inc
+inherit native
+DEPENDS = "zlib-native"
+PR = "${INC_PR}.1"
+
+do_stage () {
+ autotools_stage_all
+}
+
+do_install() {
+ :
+}
diff --git a/recipes/curl/curl-sdk_7.18.2.bb b/recipes/curl/curl-sdk_7.18.2.bb
index 35b0d8883f..8eed3d664a 100644
--- a/recipes/curl/curl-sdk_7.18.2.bb
+++ b/recipes/curl/curl-sdk_7.18.2.bb
@@ -1,7 +1,7 @@
require curl-common.inc
inherit sdk
DEPENDS = "zlib-sdk"
-PR = "r1"
+PR = "${INC_PR}.1"
do_stage () {
install -d ${STAGING_INCDIR}/curl
diff --git a/recipes/curl/curl_7.18.2.bb b/recipes/curl/curl_7.18.2.bb
index 3de6da4fec..84c0d07e61 100644
--- a/recipes/curl/curl_7.18.2.bb
+++ b/recipes/curl/curl_7.18.2.bb
@@ -1,4 +1,4 @@
require curl-common.inc
require curl-target.inc
-PR = "r1"
+PR = "${INC_PR}.1"
diff --git a/recipes/curl/curl_7.19.5.bb b/recipes/curl/curl_7.19.5.bb
index b5b6182e8d..d0577b06aa 100644
--- a/recipes/curl/curl_7.19.5.bb
+++ b/recipes/curl/curl_7.19.5.bb
@@ -3,4 +3,4 @@ require curl-target.inc
SRC_URI += "file://off_t_abi_fix.patch;patch=1;pnum=0 \
file://curl-add_all_algorithms.patch;patch=1"
-PR = "r1"
+PR = "${INC_PR}.1"
diff --git a/recipes/curl/curl_7.19.6.bb b/recipes/curl/curl_7.19.6.bb
new file mode 100644
index 0000000000..e8319b80ed
--- /dev/null
+++ b/recipes/curl/curl_7.19.6.bb
@@ -0,0 +1,5 @@
+require curl-common.inc
+require curl-target.inc
+
+SRC_URI += "file://off_t_abi_fix.patch;patch=1;pnum=0"
+PR = "${INC_PR}.1"
diff --git a/recipes/libsdl/libsdl-mixer_1.2.9.bb b/recipes/libsdl/libsdl-mixer_1.2.9.bb
new file mode 100644
index 0000000000..5ecd2944a2
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer_1.2.9.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libmikmod libvorbis"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+inherit autotools_stage
+
+EXTRA_OECONF = "--disable-music-mp3"
+# although we build smpeg... need to find out how
+# to deal with optional dependencies
+
+do_compile() {
+ # Override SDL_LIBS to include a linker rpath so the linker
+ # can find the correct libdl.so when it links playwave to
+ # libSDL_mixer.so.
+ oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
+}