summaryrefslogtreecommitdiff
path: root/recipes/xorg-lib/libx11
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-24 20:09:24 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-25 15:44:27 +0200
commit82dd23467d2a7dd7c3c2b3a32635f8e925c7d589 (patch)
treed04ae6ce563ea118c26c3ba546a3b9639bc5e4d7 /recipes/xorg-lib/libx11
parent2e0f5099dae869f19984b67a75ff166b345b31db (diff)
libx11: convert to BBCLASSEXTEND
* common patches in new libx11.inc (some needed to be renamed to keep same name across version) * keep one common dir with diet-x11/libx11-trip variants * enable xcb again for non-native non-sdk versions newer than 1.3 and add libx11-xcb package, XCB seems more popular then in 2007 (xls* projects were coverted lately, so this actually reverts patch from bug #3372) * also xcb enabled makes mesa build after libxcb was staged (mesa itself has xcb disabled, but if it founds libxcb, then it expects to find libx11 with xcb too) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/xorg-lib/libx11')
-rw-r--r--recipes/xorg-lib/libx11/include_fix.patch62
-rw-r--r--recipes/xorg-lib/libx11/makekeys-update.patch87
-rw-r--r--recipes/xorg-lib/libx11/makekeys.diff12
-rw-r--r--recipes/xorg-lib/libx11/x11_disable_makekeys.1.6.3.patch24
4 files changed, 87 insertions, 98 deletions
diff --git a/recipes/xorg-lib/libx11/include_fix.patch b/recipes/xorg-lib/libx11/include_fix.patch
deleted file mode 100644
index 565308834e..0000000000
--- a/recipes/xorg-lib/libx11/include_fix.patch
+++ /dev/null
@@ -1,62 +0,0 @@
----
- configure.ac | 44 ++++++++++++++++++++++++--------------------
- 1 file changed, 24 insertions(+), 20 deletions(-)
-
-Index: libX11-1.1.2/configure.ac
-===================================================================
---- libX11-1.1.2.orig/configure.ac 2008-01-02 15:30:47.000000000 +0000
-+++ libX11-1.1.2/configure.ac 2008-01-02 15:47:25.000000000 +0000
-@@ -207,29 +207,33 @@ AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL,
- #
- KEYSYMDEF=""
- AC_MSG_CHECKING([keysymdef.h])
--for flag in $XPROTO_CFLAGS -I/usr/include; do
-- case "$KEYSYMDEF" in
-- "")
-- case "$flag" in
-- *-I*)
-- dir=`echo "$flag" | sed 's/ *-I//'`
-- file="$dir/X11/keysymdef.h"
-- if test -f "$file"; then
-- KEYSYMDEF="$file"
-- fi
-+AC_ARG_WITH(keysymdef,
-+ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
-+ KEYSYMDEF=$withval, KEYSYMDEF="")
-+
-+if test x$KEYSYMDEF = x; then
-+ for flag in $XPROTO_CFLAGS -I/usr/include; do
-+ case "$KEYSYMDEF" in
-+ "")
-+ case "$flag" in
-+ *-I*)
-+ dir=`echo "$flag" | sed 's/ *-I//'`
-+ file="$dir/X11/keysymdef.h"
-+ if test -f "$file"; then
-+ KEYSYMDEF="$file"
-+ fi
-+ ;;
-+ esac
- ;;
- esac
-- ;;
-- esac
--done
--case "$KEYSYMDEF" in
--"")
-- AC_MSG_ERROR([Cannot find keysymdef.h])
-- ;;
--*)
-+ done
-+fi
-+
-+if test -f "$KEYSYMDEF"; then
- AC_MSG_RESULT([$KEYSYMDEF])
-- ;;
--esac
-+else
-+ AC_MSG_ERROR([Cannot find keysymdef.h])
-+fi
- AC_SUBST(KEYSYMDEF)
-
- AC_ARG_ENABLE(udc,
diff --git a/recipes/xorg-lib/libx11/makekeys-update.patch b/recipes/xorg-lib/libx11/makekeys-update.patch
new file mode 100644
index 0000000000..323dbbbbbd
--- /dev/null
+++ b/recipes/xorg-lib/libx11/makekeys-update.patch
@@ -0,0 +1,87 @@
+From f8613deafdc7c6f3be49c3448e011426bcfdf78e Mon Sep 17 00:00:00 2001
+From: Holger Hans Peter Freyther <zecke@selfish.org>
+Date: Tue, 28 Jul 2009 03:20:20 +0200
+Subject: [PATCH] makekeys.c: Replace with the latest version to fix a segfault
+
+Fix a crash..
+---
+ src/util/makekeys.c | 28 +++++++++++++++++-----------
+ 1 files changed, 17 insertions(+), 11 deletions(-)
+
+diff --git a/src/util/makekeys.c b/src/util/makekeys.c
+index 214ea5c..3fe8a96 100644
+--- a/src/util/makekeys.c
++++ b/src/util/makekeys.c
+@@ -36,13 +36,10 @@ from The Open Group.
+ #include <X11/keysymdef.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+-#if defined(macII) && !defined(__STDC__) /* stdlib.h fails to define these */
+-char *malloc();
+-#endif /* macII */
+
+ typedef unsigned long Signature;
+
+-#define KTNUM 3000
++#define KTNUM 4000
+
+ static struct info {
+ char *name;
+@@ -52,11 +49,11 @@ static struct info {
+ #define MIN_REHASH 15
+ #define MATCHES 10
+
+-char tab[KTNUM];
+-unsigned short offsets[KTNUM];
+-unsigned short indexes[KTNUM];
+-KeySym values[KTNUM];
+-char buf[1024];
++static char tab[KTNUM];
++static unsigned short offsets[KTNUM];
++static unsigned short indexes[KTNUM];
++static KeySym values[KTNUM];
++static char buf[1024];
+
+ int
+ main(int argc, char *argv[])
+@@ -103,12 +100,11 @@ main(int argc, char *argv[])
+ key);
+ continue;
+ }
+- name = malloc((unsigned)strlen(key)+1);
++ name = strdup(key);
+ if (!name) {
+ fprintf(stderr, "makekeys: out of memory!\n");
+ exit(1);
+ }
+- (void)strcpy(name, key);
+ info[ksnum].name = name;
+ ksnum++;
+ if (ksnum == KTNUM) {
+@@ -157,6 +153,11 @@ next1: ;
+ }
+
+ z = best_z;
++ if (z == 0) {
++ fprintf(stderr, "makekeys: failed to find small enough hash!\n"
++ "Try increasing KTNUM in makekeys.c\n");
++ exit(1);
++ }
+ printf("#ifdef NEEDKTABLE\n");
+ printf("const unsigned char _XkeyTable[] = {\n");
+ printf("0,\n");
+@@ -237,6 +238,11 @@ next2: ;
+ }
+
+ z = best_z;
++ if (z == 0) {
++ fprintf(stderr, "makekeys: failed to find small enough hash!\n"
++ "Try increasing KTNUM in makekeys.c\n");
++ exit(1);
++ }
+ for (i = z; --i >= 0;)
+ offsets[i] = 0;
+ for (i = 0; i < ksnum; i++) {
+--
+1.6.3.3
+
diff --git a/recipes/xorg-lib/libx11/makekeys.diff b/recipes/xorg-lib/libx11/makekeys.diff
deleted file mode 100644
index cea08725ec..0000000000
--- a/recipes/xorg-lib/libx11/makekeys.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nru libX11-X11R7.1-1.0.1.org/src/util/makekeys.c libX11-X11R7.1-1.0.1/src/util/makekeys.c
---- libX11-X11R7.1-1.0.1.org/src/util/makekeys.c 2007-03-08 14:34:34.000000000 +0100
-+++ libX11-X11R7.1-1.0.1/src/util/makekeys.c 2007-03-08 14:34:58.000000000 +0100
-@@ -49,7 +49,7 @@
- KeySym val;
- } info[KTNUM];
-
--#define MIN_REHASH 10
-+#define MIN_REHASH 15
- #define MATCHES 10
-
- char tab[KTNUM];
diff --git a/recipes/xorg-lib/libx11/x11_disable_makekeys.1.6.3.patch b/recipes/xorg-lib/libx11/x11_disable_makekeys.1.6.3.patch
deleted file mode 100644
index 4358f79896..0000000000
--- a/recipes/xorg-lib/libx11/x11_disable_makekeys.1.6.3.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -uNr libX11-1.2.99.901.orig/src/util/Makefile.am libX11-1.2.99.901/src/util/Makefile.am
---- libX11-1.2.99.901.orig/src/util/Makefile.am 2009-08-12 13:21:19.000000000 +0200
-+++ libX11-1.2.99.901/src/util/Makefile.am 2009-08-12 13:22:21.000000000 +0200
-@@ -1,20 +1,3 @@
- # $XdotOrg: lib/X11/src/util/Makefile.am,v 1.4 2006-02-19 02:14:12 jamey Exp $
-
--noinst_PROGRAMS=makekeys
--
--makekeys_CFLAGS=$(X11_CFLAGS)
--
--CC = @CC_FOR_BUILD@
--
- EXTRA_DIST = mkks.sh
--
--if LINT
--# Check source code with tools like lint & sparse
--
--ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
-- $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS)
--
--lint:
-- $(LINT) $(ALL_LINT_FLAGS) makekeys.c
--
--endif LINT