summaryrefslogtreecommitdiff
path: root/recipes/xorg-app/xterm_207.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/xorg-app/xterm_207.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/xorg-app/xterm_207.bb')
-rw-r--r--recipes/xorg-app/xterm_207.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/xorg-app/xterm_207.bb b/recipes/xorg-app/xterm_207.bb
new file mode 100644
index 0000000000..f8ed913117
--- /dev/null
+++ b/recipes/xorg-app/xterm_207.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "xterm is the standard terminal emulator for the X Window System."
+SECTION = "x11/applications"
+LICENSE = "MIT-X"
+
+DEPENDS = "libxaw xproto virtual/libx11 xextproto xext xau libxpm ncurses"
+
+SRC_URI = "${XORG_MIRROR}/development/X11R7.0-RC4/extras/${PN}-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += " /usr/lib/X11"
+
+#EXTRA_OERECONF = " -I${S}/xterm.m4"
+EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR} FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config --disable-imake"
+
+#do_configure_prepend () {
+# mv ${S}/aclocal.m4 ${S}/xterm.m4
+#}
+do_configure() {
+
+ sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
+
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}