summaryrefslogtreecommitdiff
path: root/recipes/xml-commons/xom_1.1.bb
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:04:01 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:04:01 +0200
commit2e7c334a4f6b0882ee90c8be91f81d24e4d82496 (patch)
tree11c29c8c61eb8679015869fea7aab5e51cd8eec7 /recipes/xml-commons/xom_1.1.bb
parent04800cfdf823ea3003eb1164c4d5dfd7e1db5679 (diff)
dom4j 1.6.1: New recipe (for Jalimo SVN).
dom4j-native 1.6.1: Dito. jaxen 1.1.1: Dito. xom 1.1: Dito. xpp2 2.1.10: Dito. xpp3 1.1.3.4.0: Dito.
Diffstat (limited to 'recipes/xml-commons/xom_1.1.bb')
-rw-r--r--recipes/xml-commons/xom_1.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/xml-commons/xom_1.1.bb b/recipes/xml-commons/xom_1.1.bb
new file mode 100644
index 0000000000..1ef64a49f2
--- /dev/null
+++ b/recipes/xml-commons/xom_1.1.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Tree-based API for processing XML with Java"
+LICENSE = "LGPL"
+
+HOMEPAGE = "http://xom.nu"
+
+SRC_URI = "\
+ http://www.cafeconleche.org/XOM/${P}-src.tar.gz \
+ http://dist.codehaus.org/jaxen/distributions/jaxen-1.1.1-src.tar.gz \
+ file://04_remove_sun_import.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/XOM"
+
+inherit java-library
+
+DEPENDS = "fastjar-native xerces-j xalan-j"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s xercesImpl xalan2
+ cp=build:$cp
+
+ scp="${WORKDIR}/jaxen-1.1.1/src/java/main"
+
+ javac -sourcepath src:$scp -cp $cp -d build `find src -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)`
+ javac -sourcepath fatsrc:$scp -cp $cp -d build `find fatsrc -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)`
+ javac -sourcepath src15:$scp -cp $cp -d build `find src15 -name "*.java" -and -not \( -wholename "*tests*" -or -wholename "*samples*" -or -wholename "*tools*" \)`
+
+ (cd src && find . -name "*.properties" -exec cp {} ../build/{} \;)
+
+ # Remove Jaxen classes from build
+ rm -rf build/org/jaxen
+ rm -rf build/org/w3c
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}