summaryrefslogtreecommitdiff
path: root/recipes/xml-commons/jaxen_1.1.1.bb
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:04:01 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:04:01 +0200
commit2e7c334a4f6b0882ee90c8be91f81d24e4d82496 (patch)
tree11c29c8c61eb8679015869fea7aab5e51cd8eec7 /recipes/xml-commons/jaxen_1.1.1.bb
parent04800cfdf823ea3003eb1164c4d5dfd7e1db5679 (diff)
dom4j 1.6.1: New recipe (for Jalimo SVN).
dom4j-native 1.6.1: Dito. jaxen 1.1.1: Dito. xom 1.1: Dito. xpp2 2.1.10: Dito. xpp3 1.1.3.4.0: Dito.
Diffstat (limited to 'recipes/xml-commons/jaxen_1.1.1.bb')
-rw-r--r--recipes/xml-commons/jaxen_1.1.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/xml-commons/jaxen_1.1.1.bb b/recipes/xml-commons/jaxen_1.1.1.bb
new file mode 100644
index 0000000000..d78f303cde
--- /dev/null
+++ b/recipes/xml-commons/jaxen_1.1.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "XPath library written in Java"
+LICENSE = "BSD"
+
+HOMEPAGE = "http://jaxen.codehaus.org/
+
+DEPENDS = "fastjar-native xerces-j xom"
+
+SRC_URI = "\
+ http://dist.codehaus.org/jaxen/distributions/jaxen-${PV}-src.tar.gz \
+ http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz \
+ "
+
+inherit java-library
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s xercesImpl xom
+ scp="src/java/main:${WORKDIR}/jdom-1.1/src/java"
+
+ javac -sourcepath $scp -cp $cp -d build `find src/java/main -name "*.java" -and -not -wholename "*dom4j*"`
+ (cd src && find org -name "*.properties" -exec cp {} ../build/{} \;)
+
+ rm -rf build/org/jdom
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
+