summaryrefslogtreecommitdiff
path: root/recipes/xfce/libxfce4util_4.4.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/xfce/libxfce4util_4.4.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xfce/libxfce4util_4.4.2.bb')
-rw-r--r--recipes/xfce/libxfce4util_4.4.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/xfce/libxfce4util_4.4.2.bb b/recipes/xfce/libxfce4util_4.4.2.bb
new file mode 100644
index 0000000000..3386ad57e3
--- /dev/null
+++ b/recipes/xfce/libxfce4util_4.4.2.bb
@@ -0,0 +1,26 @@
+# libxfce4util OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION = "Basic utility library for Xfce4"
+SECTION = "x11/libs"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 xfce4-dev-tools"
+
+inherit xfce pkgconfig
+
+MACROS="m4/X11.m4 m4/debug.m4 m4/depends.m4 m4/i18n.m4"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/libxfce4util
+ # The line below expands to the list of headers that native makefile
+ # would install. Complain and/or fix if it's not portable enough
+ for file in $(eval $(make -n -C libxfce4util install|grep "^list='[^.]\\+.h"|cut -d\; -f1); echo $list); do
+ install -m 644 libxfce4util/$file ${STAGING_INCDIR}/libxfce4util
+ done
+
+ oe_libinstall -C libxfce4util -so libxfce4util ${STAGING_LIBDIR}
+
+}
+
+FILES_${PN}-dev += " ${datadir}/xfce4/m4"