summaryrefslogtreecommitdiff
path: root/recipes/xfce-base/exo_0.3.4.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-10-25 10:52:51 +0000
committerKoen Kooi <koen@openembedded.org>2009-10-27 15:26:58 +0100
commitcf508f496dae24acc1b4fd3cecb5dd191b5d69b6 (patch)
tree0138c2b6b924c7426a510404256173adca53e8e6 /recipes/xfce-base/exo_0.3.4.bb
parenteeac84ae328fa18770c3724a23ff847f954f60dc (diff)
XFCE: Rename xfce to xfce-base to support the import of the new XFCE 4.6.1 builds.
Diffstat (limited to 'recipes/xfce-base/exo_0.3.4.bb')
-rw-r--r--recipes/xfce-base/exo_0.3.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/xfce-base/exo_0.3.4.bb b/recipes/xfce-base/exo_0.3.4.bb
new file mode 100644
index 0000000000..17ea87d3d3
--- /dev/null
+++ b/recipes/xfce-base/exo_0.3.4.bb
@@ -0,0 +1,21 @@
+DEPENDS = "libxfce4util xfce-mcs-manager hal liburi-perl-native python-native"
+
+inherit xfce
+XFCE_VERSION = 4.4.2
+
+SRC_URI += " file://configure.patch;patch=1"
+SRC_URI += " file://exo-no-tests.patch;patch=1"
+
+# Note: Python checking is broken
+do_configure_prepend() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.in
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/xfce4/ \
+ ${libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.so"
+FILES_${PN}-dev += "${libdir}/xfce4/mcs-plugins/exo-preferred-applications-settings.*"
+FILES_${PN}-dbg += "${libdir}/xfce4/mcs-plugins/.debug/exo-preferred-applications-settings.*"