summaryrefslogtreecommitdiff
path: root/recipes/wget/wget_1.9.1.bb
diff options
context:
space:
mode:
authorMatthieu Poullet <matthieu.poullet@gmail.com>2009-05-21 05:44:17 +0000
committerKoen Kooi <koen@openembedded.org>2009-05-22 13:29:51 +0200
commit567e88579c580194d560f4c422930d4de6487d3c (patch)
treedfbfcfc4ceb1f399f134ee9e0a026a366f4fee4c /recipes/wget/wget_1.9.1.bb
parentf924eacf0f48f8d273d9fb1f63109d6e576f5e7c (diff)
wget: update to version 1.11.4
The actual version was released in 2003, so I think it's time to update it. This patch prepares the transition and allows other to test the latest release. Regards, Matthieu. Signed-off-by: Matthieu Poullet <matthieu.poullet@gmail.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/wget/wget_1.9.1.bb')
-rw-r--r--recipes/wget/wget_1.9.1.bb41
1 files changed, 10 insertions, 31 deletions
diff --git a/recipes/wget/wget_1.9.1.bb b/recipes/wget/wget_1.9.1.bb
index b1e9404c01..50974ed87b 100644
--- a/recipes/wget/wget_1.9.1.bb
+++ b/recipes/wget/wget_1.9.1.bb
@@ -1,40 +1,19 @@
-DESCRIPTION = "A console URL download utility featuring HTTP, FTP, and more."
-SECTION = "console/network"
-DEPENDS = ""
-PR = "r7"
-LICENSE = "GPL"
+PR = "${INC_PR}.1"
-SRC_URI = "${GNU_MIRROR}/wget/wget-${PV}.tar.gz \
- file://m4macros.patch;patch=1 \
- file://autotools.patch;patch=1 \
- file://ipv6-fix.patch;patch=1"
-S = "${WORKDIR}/wget-${PV}"
-
-inherit autotools gettext
-
-# Disable checking for SSL since that searches the system paths
-EXTRA_OECONF = "--enable-ipv6 --without-ssl"
+SRC_URI = " \
+ ${GNU_MIRROR}/wget/wget-${PV}.tar.gz \
+ file://m4macros.patch;patch=1 \
+ file://autotools.patch;patch=1 \
+ file://ipv6-fix.patch;patch=1 \
+"
-# SlugOS kernels do not support ipv6. Can be loaded as a module.
-EXTRA_OECONF_slugos = "--without-ssl"
+S = "${WORKDIR}/wget-${PV}"
-do_configure () {
+do_configure_prepend () {
if [ ! -e acinclude.m4 ]; then
mv aclocal.m4 acinclude.m4
fi
rm -f libtool.m4
- autotools_do_configure
}
-do_install () {
- autotools_do_install
- mv ${D}${bindir}/wget ${D}${bindir}/wget.${PN}
-}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${bindir}/wget wget wget.${PN} 100
-}
-
-pkg_prerm_${PN} () {
- update-alternatives --remove wget wget.${PN}
-}
+require wget.inc