summaryrefslogtreecommitdiff
path: root/recipes/watchdog/watchdog_5.6.bb
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-04-17 16:24:46 -0400
committerTom Rini <trini@embeddedalley.com>2009-04-17 16:24:46 -0400
commitc8b3cc5ef81d305d5d90644da36acbc40c7c01f1 (patch)
treec5780e1ec137dd4cf71d54ba07e41d7795148b75 /recipes/watchdog/watchdog_5.6.bb
parent49a720ff8597243a906d7c0f9278ca8f1f9ff670 (diff)
parenta4f79016c537fc93e5a487d51a22fb4d01e9afe8 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/watchdog/watchdog_5.6.bb')
-rw-r--r--recipes/watchdog/watchdog_5.6.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/watchdog/watchdog_5.6.bb b/recipes/watchdog/watchdog_5.6.bb
new file mode 100644
index 0000000000..6c8bd56e73
--- /dev/null
+++ b/recipes/watchdog/watchdog_5.6.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "System watchdog daemon"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${PN}-${PV}.tar.gz \
+ file://init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "watchdog"
+INITSCRIPT_PARAMS = "defaults 10"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/watchdog
+}
+