summaryrefslogtreecommitdiff
path: root/recipes/udhcp/files/install.patch
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/udhcp/files/install.patch
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/udhcp/files/install.patch')
-rw-r--r--recipes/udhcp/files/install.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/recipes/udhcp/files/install.patch b/recipes/udhcp/files/install.patch
new file mode 100644
index 0000000000..7cec1c087f
--- /dev/null
+++ b/recipes/udhcp/files/install.patch
@@ -0,0 +1,64 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- udhcp-0.9.8/Makefile~install.patch
++++ udhcp-0.9.8/Makefile
+@@ -1,10 +1,11 @@
+ # udhcp makefile
+
++DESTDIR=
+ prefix=/usr
+-SBINDIR=/sbin
+-USRSBINDIR=${prefix}/sbin
+-USRBINDIR=${prefix}/bin
+-USRSHAREDIR=${prefix}/share
++sbindir=/sbin
++usrsbindir=$(prefix)/sbin
++usrbindir=$(prefix)/bin
++datadir=$(prefix)/share
+
+ # Uncomment this to get a shared binary. Call as udhcpd for the server,
+ # and udhcpc for the client
+@@ -81,25 +82,27 @@
+
+
+ install: all
+-
+- $(INSTALL) $(DAEMONS) $(USRSBINDIR)
+- $(INSTALL) $(COMMANDS) $(USRBINDIR)
++ $(INSTALL) -d $(DESTDIR)$(usrsbindir)
++ $(INSTALL) $(DAEMONS) $(DESTDIR)$(usrsbindir)
++ $(INSTALL) -d $(DESTDIR)$(usrbindir)
++ $(INSTALL) $(COMMANDS) $(DESTDIR)$(usrbindir)
++ $(INSTALL) -d $(DESTDIR)$(sbindir)
+ ifdef COMBINED_BINARY
+- ln -sf $(USRSBINDIR)/$(DAEMONS) $(SBINDIR)/$(BOOT_PROGRAMS)
++ ln -sf $(usrsbindir)/$(DAEMONS) $(DESTDIR)$(sbindir)/$(BOOT_PROGRAMS)
+ else
+- $(INSTALL) $(BOOT_PROGRAMS) $(SBINDIR)
++ $(INSTALL) $(BOOT_PROGRAMS) $(DESTDIR)$(sbindir)
+ endif
+- mkdir -p $(USRSHAREDIR)/udhcpc
++ $(INSTALL) -d $(DESTDIR)$(datadir)/udhcpc
+ for name in bound deconfig renew script ; do \
+ $(INSTALL) samples/sample.$$name \
+- $(USRSHAREDIR)/udhcpc/default.$$name ; \
++ $(DESTDIR)$(datadir)/udhcpc/default.$$name ; \
+ done
+- mkdir -p $(USRSHAREDIR)/man/man1
+- $(INSTALL) dumpleases.1 $(USRSHAREDIR)/man/man1
+- mkdir -p $(USRSHAREDIR)/man/man5
+- $(INSTALL) udhcpd.conf.5 $(USRSHAREDIR)/man/man5
+- mkdir -p $(USRSHAREDIR)/man/man8
+- $(INSTALL) udhcpc.8 udhcpd.8 $(USRSHAREDIR)/man/man8
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man1
++ $(INSTALL) dumpleases.1 $(DESTDIR)$(mandir)/man1
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man5
++ $(INSTALL) udhcpd.conf.5 $(DESTDIR)$(mandir)/man5
++ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
++ $(INSTALL) udhcpc.8 udhcpd.8 $(DESTDIR)$(mandir)/man8
+
+ clean:
+ -rm -f udhcpd udhcpc dumpleases *.o core