summaryrefslogtreecommitdiff
path: root/recipes/ti/ti-lpm-module_2.24.01.bb
diff options
context:
space:
mode:
authorKoen Kooi <k-kooi@ti.com>2009-11-16 10:17:24 +0100
committerKoen Kooi <koen@openembedded.org>2009-12-04 19:46:02 +0100
commitb788499815bfc1974d4277c0a261b9a7c24aa816 (patch)
tree6c0546c0891d884f835355d851ec07147165ddd2 /recipes/ti/ti-lpm-module_2.24.01.bb
parent08dcecdc77ceb6a3673605216493905859f11982 (diff)
recipes/ti: merge in updates
* New codec recipes from Arago team in Germantown * Updated dm6446 and dm355 from Brijesh Singh * cmem, gst-ti and dmai fixes from Brijesh Singh angstrom: introduce SOC_FAMILY and start using it TI recipes as a testing ground * SOC_FAMILY tells you which system on chip is used in the MACHINE, e.g. omap3, dm355, pxa25x, s3c24xx. This avoids having to duplicate lots of overrides in machine specific recipes. This is *NOT* intended to be used as a package arch.
Diffstat (limited to 'recipes/ti/ti-lpm-module_2.24.01.bb')
-rw-r--r--recipes/ti/ti-lpm-module_2.24.01.bb45
1 files changed, 13 insertions, 32 deletions
diff --git a/recipes/ti/ti-lpm-module_2.24.01.bb b/recipes/ti/ti-lpm-module_2.24.01.bb
index 8c41dbf8c2..32bc02b1e5 100644
--- a/recipes/ti/ti-lpm-module_2.24.01.bb
+++ b/recipes/ti/ti-lpm-module_2.24.01.bb
@@ -1,29 +1,24 @@
DESCRIPTION = "LPM module for TI OMAP3 processors"
-require ti-paths.inc
-
-inherit module
-# compile and run time dependencies
-DEPENDS = " virtual/kernel perl-native ti-dsplink-module"
-
-#This is a kernel module, don't set PR directly
-MACHINE_KERNEL_PR_append = "a"
+DEPENDS = "ti-linuxutils"
-PV = "2241"
+# tconf breaks with '.' in PWD
+PV = "2_24_01"
SRC_URI = "http://install.source.dir.local/local_power_manager_1_24.tar.gz"
# Set the source directory
S = "${WORKDIR}/local_power_manager_1_24"
-do_compile () {
- # TODO :: KERNEL_CC, etc need replacing with user CC
- # TODO :: Need to understand why OBJDUMP is required for kernel module
- # Unset these since LDFLAGS gets picked up and used incorrectly.... need
- # investigation
+require ti-paths.inc
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+#This is a kernel module, don't set PR directly
+MACHINE_KERNEL_PR_append = "a"
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
cd ${S}/packages/ti/bios/power/modules/${LPMDSPPOWERSOC}/lpm
make \
DSPLINK_REPO="${DSPLINK}/.." \
@@ -33,27 +28,13 @@ do_compile () {
}
do_install () {
-
# LPM/CMEM/SDMA drivers - kernel modules
install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
- install -m 0755 ${S}/packages/ti/bios/power/modules/${LPMDSPPOWERSOC}/lpm/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+ install -m 0755 ${S}/packages/ti/bios/power/modules/${LPMDSPPOWERSOC}/lpm/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
}
-
-pkg_postinst () {
- if [ -n "$D" ]; then
- exit 1
- fi
- depmod -a
- update-modules || true
-}
-
-pkg_postrm () {
- update-modules || true
-}
-
-INHIBIT_PACKAGE_STRIP = "1"
+RDEPENDS_${PN} += " ti-dsplink-module"
FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/*lpm*ko"
-RDEPENDS += " ti-dsplink-module"
+INHIBIT_PACKAGE_STRIP = "1"