summaryrefslogtreecommitdiff
path: root/recipes/ti/ti-codecs-dm6446_2.05.00.00.bb
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-02-25 12:44:16 +0000
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:20 +0200
commit73efa8afa568d88ebf94563e9200fbcdfb669fbe (patch)
treef28dc8590211701d69c3a607c98ba0108913406c /recipes/ti/ti-codecs-dm6446_2.05.00.00.bb
parent893cba6c8ad21270753654af0d16fbed0288cc91 (diff)
ti recipes: Start moving /files into package specific directories
ti-codec-engine: Cleanup Codec Engine Recipe * Fix Installer Issues * Cleanup Variable Names + Add for all targets * Remove non-tspa older 2.24.01 recipe * Add omapl137 depends ti-xdais: Recipe Cleanup ti-dsplink: Add runscript to run all example applications (for easy testing) * Add run script * Rename load/unload scripts for consistency * Use _append instead of += for RDEPENDS * ti-dsplink: fix GPPOS for omapl137 * SED out CROSS_COMPILE from dsplink Makefile gstreamer-ti: Recipe Cleanup align with other recipes * Recipe cleanup, cosmetics * Move required variables inside recipe * Ensure all targets have variables assigned * Add -rc scripts for all targets * Add runtime recommends for all targets * Needs LINUXKERNEL_INSTALL_DIR setting * export LINUXKERNEL_INSTALL_DIR for gstreamer_ti * add logic for patching to newer kernel (mach/omapfb) * don't error out if the sed on omapfb fails since the header won't be there for non-omap3 ti-codecs: Recipe cleanup for omapl, omap3 and dm6446 * Cleanup of omap3, omapl138, omapl137, dm6446 * Start building omapl138 recipe * Add prepsources step * Package codecs into -server package * Add qualiTI reports and codec data sheet * Variable cleanup * Set stage for common codec build recipe * Temp comment out variables, for removal in subsequent commit after validation ti-dmai: Recipe cleanup * Recipe cleanup, cosmetics * Move required variables inside recipe, remove unused variables * Runtime deps for -apps, -tests * Add loadmodules script for omapl137 * Need to pass path to CE 'example' codecs for arm side audio codec (g711) ti-local-power-manager: Set XDC_PLATFORM * lpm needs XDC platform defined. Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti/ti-codecs-dm6446_2.05.00.00.bb')
-rw-r--r--recipes/ti/ti-codecs-dm6446_2.05.00.00.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/recipes/ti/ti-codecs-dm6446_2.05.00.00.bb b/recipes/ti/ti-codecs-dm6446_2.05.00.00.bb
new file mode 100644
index 0000000000..0331b21f37
--- /dev/null
+++ b/recipes/ti/ti-codecs-dm6446_2.05.00.00.bb
@@ -0,0 +1,88 @@
+DESCRIPTION = "TI Codecs (and Server Combo) for DM6446"
+HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent"
+SECTION = "multimedia"
+
+# TODO :: Move to common .inc (omap3 and omapl ready)
+# TODO :: XDCARGS = eval in this server?
+
+PV = "2_05_00_00"
+
+SRC_URI[dm6446codecsbin.md5sum] = "4db567252e6c43119e1c0aafe401a679"
+SRC_URI[dm6446codecsbin.sha256sum] = "e042e1aad42a6728adf5c955dc38e4f8331fc0eacd833f1cd75d9cbb4faff0b5"
+
+PR = "r17"
+
+require ti-paths.inc
+require ti-staging.inc
+require ti-eula-unpack.inc
+
+PROVIDES += "ti-codecs-dm6446-server"
+
+S = "${WORKDIR}/dvsdk_2_00_00_22/dm6446_dvsdk_combos_2_05"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/S1SDKLNX/DVSDK_2_00/exports/dm6446_codecs_setuplinux_2_00_00_22.bin;name=dm6446codecsbin"
+
+BINFILE = "dm6446_codecs_setuplinux_2_00_00_22.bin"
+TI_BIN_UNPK_CMDS = "Y: qY:workdir:Y"
+
+DEPENDS = "ti-cgt6x ti-xdctools ti-dspbios ti-codec-engine ti-linuxutils"
+
+#generic codec
+DSPSUFFIX_dm6446 = "x64P"
+
+do_prepsources() {
+
+ make \
+ CE_INSTALL_DIR=${CE_INSTALL_DIR} \
+ FC_INSTALL_DIR=${FC_INSTALL_DIR} \
+ LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
+ CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
+ LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
+ BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
+ CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
+ XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
+ CODEC_INSTALL_DIR="${S}" \
+ XDCARGS="eval" \
+ clean
+}
+
+addtask prepsources after do_configure before do_compile
+
+do_compile() {
+
+ make \
+ CE_INSTALL_DIR=${CE_INSTALL_DIR} \
+ FC_INSTALL_DIR=${FC_INSTALL_DIR} \
+ LINK_INSTALL_DIR=${LINK_INSTALL_DIR} \
+ CMEM_INSTALL_DIR=${CMEM_INSTALL_DIR} \
+ LPM_INSTALL_DIR=${LPM_INSTALL_DIR} \
+ BIOS_INSTALL_DIR=${BIOS_INSTALL_DIR} \
+ CODEGEN_INSTALL_DIR=${CODEGEN_INSTALL_DIR} \
+ XDC_INSTALL_DIR=${XDC_INSTALL_DIR} \
+ CODEC_INSTALL_DIR="${S}" \
+ XDCARGS="eval" \
+ all
+}
+
+do_install() {
+
+ install -d ${D}/${installdir}/ti-codecs-server
+ cd ${S}
+
+ # Install the DSP Server Binary
+ for file in `find . -name *.${DSPSUFFIX}`; do
+ cp ${file} ${D}/${installdir}/ti-codecs-server
+ done
+
+ # Install docs (codec qualiTI test reports, server config datasheet, etc)
+ for file in `find . -name *.html`; do
+ cp ${file} ${D}/${installdir}/ti-codecs-server
+ done
+
+ install -d ${D}${CODEC_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${CODEC_INSTALL_DIR_RECIPE}
+}
+
+PACKAGES += "ti-codecs-dm6446-server"
+FILES_ti-codecs-dm6446-server = "${installdir}/ti-codecs-server/*"
+