summaryrefslogtreecommitdiff
path: root/recipes/ti/matrix-gui-common
diff options
context:
space:
mode:
authorChase Maupin <chase.maupin@ti.com>2010-05-27 11:01:30 -0500
committerKoen Kooi <koen@openembedded.org>2010-05-28 09:21:15 +0200
commit617eb0ac559bd46ae86a6fd9a270d862ee9adf56 (patch)
tree3018c913fd5037777556357288e90712766923ee /recipes/ti/matrix-gui-common
parent0539d1ef424c6e9851f2c213a1b36353c0d7330f (diff)
matrix-gui-common: Move common files into one pkg
* Created the matrix-gui-common_svn.bb recipe to contain all of the common html, scripts, and image files used by both versions of the matrix GUI application. * Removed the html, script, and image files from matrix-gui and matrix-gui-e recipes. * Added dependency on matrix-gui-common to matrix-gui and matrix-gui-e recipes. * Added browser executable that looks for the example browser from the Qt demos package depending on whether the embedded or X11 version of the matrix GUI application is running. Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti/matrix-gui-common')
-rw-r--r--recipes/ti/matrix-gui-common/browser20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/ti/matrix-gui-common/browser b/recipes/ti/matrix-gui-common/browser
new file mode 100644
index 0000000000..b5202d5a14
--- /dev/null
+++ b/recipes/ti/matrix-gui-common/browser
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+BROWSERDIR=""
+BROWSERAPP="browser"
+
+#Check if DISPLAY is set. If so we assume we are running in X11
+#and will call the X11 version of the browser if it exists.
+if [ "$DISPLAY" == "" ]
+then
+ BROWSERDIR="/usr/bin/qtopia/demos/browser"
+else
+ BROWSERDIR="/usr/bin/qt4/demos/browser"
+fi
+
+if [ -e "$BROWSERDIR/$BROWSERAPP" ]
+then
+ cd $BROWSERDIR
+ ./$BROWSERAPP
+fi
+