summaryrefslogtreecommitdiff
path: root/recipes/ti/gstreamer-ti_svn.bb
diff options
context:
space:
mode:
authorBrijesh Singh <a0270506@incredibles.(none)>2009-08-31 05:12:13 -0500
committerKoen Kooi <koen@openembedded.org>2009-09-01 10:12:31 +0200
commitec8b2b66c915309587078d7635910e6d41b4e81e (patch)
tree0d3b8e2b9e3e2a81108442babc867c042a741919 /recipes/ti/gstreamer-ti_svn.bb
parent40dd422071b98b49229cf188fa9ddc0c714c8787 (diff)
gstreamer-ti: merge updated patch from tracker and export CODEC_SERVER dir for the hard-coded server name
Diffstat (limited to 'recipes/ti/gstreamer-ti_svn.bb')
-rw-r--r--recipes/ti/gstreamer-ti_svn.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/recipes/ti/gstreamer-ti_svn.bb b/recipes/ti/gstreamer-ti_svn.bb
index 7d13c7186a..59f7046bac 100644
--- a/recipes/ti/gstreamer-ti_svn.bb
+++ b/recipes/ti/gstreamer-ti_svn.bb
@@ -7,13 +7,13 @@ inherit autotools
DEPENDS = "ti-dmai gstreamer gst-plugins-base gst-plugins-good gst-plugins-ugly"
# Fetch source from svn repo
-SRCREV = "285"
+SRCREV = "331"
SRC_URI = "svn://gforge.ti.com/svn/gstreamer_ti/trunk;module=gstreamer_ti;proto=https;user=anonymous;pswd='' \
file://gstreamer-ti-tracker-824.patch;patch=1 \
"
# Again, no '.' in PWD allowed :(
-PR = "r28"
+PR = "r32"
PV = "svnr${SRCREV}"
S = "${WORKDIR}/gstreamer_ti/ti_build/ticodecplugin"
@@ -36,6 +36,12 @@ CPPFLAGS_append = " -DPlatform_${PLATFORM}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+# export codec combo (or server) locations
+export HMJCP_COMBO = "${installdir}/codec-combo/hmjcp.accel"
+export CODEC_SERVER = "${installdir}/codec-combo/cs.x64P"
+export ENCODE_COMBO = "${installdir}/codec-combo/encodeCombo.x64P"
+export DECODE_COMBO = "${installdir}/codec-combo/decodeCombo.x64P"
+
do_install_prepend () {
# install gstreamer demo scripts
install -d ${D}/${installdir}/gst