summaryrefslogtreecommitdiff
path: root/recipes/ti/bitblit_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-08-26 16:10:27 +0200
committerKoen Kooi <koen@openembedded.org>2009-08-26 16:10:27 +0200
commitb6235b4c2139c14093c76088dfc0eeb34c86d913 (patch)
tree650c4ddb040bf1236063572dfb105eed9c0c169a /recipes/ti/bitblit_svn.bb
parent59ddf7ef9b172d9db65af876b211f853746d470b (diff)
ti-codec: add missing.inc
bitblit: add svn recipe
Diffstat (limited to 'recipes/ti/bitblit_svn.bb')
-rw-r--r--recipes/ti/bitblit_svn.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes/ti/bitblit_svn.bb b/recipes/ti/bitblit_svn.bb
new file mode 100644
index 0000000000..9a0a24134e
--- /dev/null
+++ b/recipes/ti/bitblit_svn.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "Low level 2D blitting/blending graphics acceleration services support on DM6446, OMAP3530 and OMAP-L137."
+
+require ti-paths.inc
+
+inherit autotools
+
+DEPENDS = "ti-codec-engine ti-dmai"
+
+# Fetch source from svn repo
+SRCREV = "2"
+SRC_URI = "svn://gforge.ti.com/svn/${PN};module=trunk;proto=https;user=anonymous;pswd='' \
+ file://recent-linux.diff;patch=1 \
+"
+
+# Again, no '.' in PWD allowed :(
+PV = "0+svnr${SRCREV}"
+PR = "r1"
+
+S = "${WORKDIR}/trunk/bitblit"
+
+XDC_TARGET = gnu.targets.arm.GCArmv5T
+XDC_PLATFORM_dm355-evm = ti.platforms.evmDM355
+XDC_PLATFORM_dm6446-evm = ti.platforms.evmDM6446
+XDC_PLATFORM_da830-omapl137-evm = ti.platforms.omapl137
+PLATFORM_XDC = ${XDC_PLATFORM}
+
+export XDC_TARGET
+export XDC_PLATFORM
+export PLATFORM_XDC
+
+PLATFORM_dm355-evm = "dm355"
+PLATFORM_dm6446-evm = "dm6446"
+PLATFORM_da830-omapl137-evm = "ol137"
+
+export LINUXLIBS_INSTALL_DIR="${STAGING_DIR_HOST}/usr"
+export EXEC_DIR = "${D}${datadir}/ti/bitblit/"
+
+CPPFLAGS_append = " -DPlatform_${PLATFORM}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_compile() {
+ oe_runmake -e all
+}
+
+do_install() {
+ oe_runmake -e install
+}