summaryrefslogtreecommitdiff
path: root/recipes/tasks/task-self-hosting.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tasks/task-self-hosting.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tasks/task-self-hosting.bb')
-rw-r--r--recipes/tasks/task-self-hosting.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/tasks/task-self-hosting.bb b/recipes/tasks/task-self-hosting.bb
new file mode 100644
index 0000000000..87604a2dab
--- /dev/null
+++ b/recipes/tasks/task-self-hosting.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "All tools needed for OpenEmbedded build"
+SECTION = "devel"
+LICENSE = "MIT"
+RDEPENDS = "cpp gcc-symlinks binutils-symlinks \
+ perl perl-modules bitbake bash \
+ task-proper-tools glibc-utils \
+ linux-libc-headers-dev glibc-dev \
+ texinfo make cvs subversion monotone-6"
+
+#
+# quilt-native REQ bash and perl/perl-modules
+# binutils REQ texinfo
+#
+# bitbake will fetch all needed python modules
+#
+# toolchain:
+# - gcc-symlinks will fetch gcc
+# - binutils-symlinks will fetch binutils
+# - glibc-utils REQ cpp
+#
+# problems:
+# - binutils-symlinks conflict with busybox
+# - glibc-dev conflict with libc-linux-headers-dev
+# - perl is so granulated that it is probably impossible
+# to find out which packages are needed
+#
+
+ALLOW_EMPTY = "1"
+
+PACKAGES = "${PN}"
+PACKAGE_ARCH = "all"