summaryrefslogtreecommitdiff
path: root/recipes/tasks/task-openmoko-ui.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/tasks/task-openmoko-ui.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/tasks/task-openmoko-ui.bb')
-rw-r--r--recipes/tasks/task-openmoko-ui.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/recipes/tasks/task-openmoko-ui.bb b/recipes/tasks/task-openmoko-ui.bb
new file mode 100644
index 0000000000..71020afef6
--- /dev/null
+++ b/recipes/tasks/task-openmoko-ui.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "Openmoko: GUI for the Openmoko Linux Distribution"
+SECTION = "openmoko/base"
+LICENSE = "MIT"
+PR = "r73"
+
+inherit task
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+#
+# task-openmoko-ui
+#
+DESCRIPTION_task-openmoko-ui = "Openmoko: The X11/Gtk+2 based native User Interface"
+PACKAGE_ARCH_task-openmoko-ui = "${MACHINE_ARCH}"
+RDEPENDS_task-openmoko-ui = "\
+ gdk-pixbuf-loader-png \
+ gdk-pixbuf-loader-gif \
+ gdk-pixbuf-loader-xpm \
+ gdk-pixbuf-loader-jpeg \
+ pango-module-basic-x \
+ pango-module-basic-fc \
+ gtk+ \
+ matchbox-wm \
+ ${XSERVER} \
+ xserver-kdrive-common \
+ xserver-nodm-init \
+ xauth \
+ xhost \
+ xset \
+ xrandr \
+ \
+ settings-daemon \
+ notification-daemon \
+ neod \
+ libnotify \
+ \
+ openmoko-session2 \
+ openmoko-sound-system2 \
+ openmoko-sound-theme-standard2 \
+ \
+ gpe-scap \
+"
+
+# Handle theming. FIXME: properly use machine database in a smart way,
+# taking into account not only size but also PPI! Ultimately this might
+# need recomputing some theme files and images on-the-fly :/ SVG and logical
+# theme description anyone? Or simply Edje to the rescue! :D
+THEMES = "openmoko-icon-theme-standard2 moko-gtk-engine"
+THEMES_a780 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_e680 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_a1200 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_rokre2 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_rokre6 = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_magician = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_chumby = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+THEMES_htcblueangel = "openmoko-icon-theme-standard2-qvga openmoko-theme-standard2-qvga"
+
+RDEPENDS_task-openmoko-ui += "${THEMES}"