summaryrefslogtreecommitdiff
path: root/recipes/sudo/sudo-enable-wheel-group.bb
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-11-09 21:32:46 +0000
committerKoen Kooi <koen@openembedded.org>2009-11-24 11:08:36 +0100
commit873c8d85d639b4996e4613d1a85b819d98c5f2be (patch)
tree2568cd468514ccc02f871d4d47463dbc71793e2e /recipes/sudo/sudo-enable-wheel-group.bb
parent4677a67913c5ec376eb016e6aac21f9a7ad5e9c4 (diff)
sudo: Add 1.7.2p1 and enable PAM support by default in newer sudo builds.
sudo.inc: Tweak include to support newer sudo versions. * Apply in addition to earlier sudo recipe bumps. * Tweak pam.d config file for sudo and add a (WIP) recipe for turning on support for the wheel group. * Update pam.d service file to suggested upstream Linux-PAM layout.
Diffstat (limited to 'recipes/sudo/sudo-enable-wheel-group.bb')
-rw-r--r--recipes/sudo/sudo-enable-wheel-group.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/sudo/sudo-enable-wheel-group.bb b/recipes/sudo/sudo-enable-wheel-group.bb
new file mode 100644
index 0000000000..b281ddb09d
--- /dev/null
+++ b/recipes/sudo/sudo-enable-wheel-group.bb
@@ -0,0 +1,20 @@
+PR = "r0"
+
+RDEPENDS = "sudo"
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "all"
+
+# Edit sudoers to allow the use of the wheel group and non root users to mount/shutdown etc.
+# Please consider this when using.
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p $D${sysconfdir}/
+touch $D${sysconfdir}/sudoers
+sed -i /# %wheel/d $D${sysconfdir}/sudoers
+echo '%wheel ALL=(ALL) ALL' >> $D${sysconfdir}/sudoers
+sed -i /# %users/d $D${sysconfdir}/sudoers
+echo '%users ALL=/sbin/mount /cdrom,/sbin/umount /cdrom' >> $D${sysconfdir}/sudoers
+echo '%users localhost=/sbin/shutdown -h now' >> $D${sysconfdir}/sudoers
+}