summaryrefslogtreecommitdiff
path: root/recipes/strace/strace_4.5.14.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-03-23 11:45:40 +0100
committerStefan Schmidt <stefan@datenfreihafen.org>2009-03-23 11:45:40 +0100
commit451b1c687105655a4f2c9c477b05535041e25060 (patch)
tree3db315590172cd6244107a97a6603add934d7e32 /recipes/strace/strace_4.5.14.bb
parent6767ca50430e37cdad0a8992b73c3f82ead134bf (diff)
parente2b99b79f516a7466dc050902cee62f39869bf9d (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/strace/strace_4.5.14.bb')
-rw-r--r--recipes/strace/strace_4.5.14.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/strace/strace_4.5.14.bb b/recipes/strace/strace_4.5.14.bb
new file mode 100644
index 0000000000..cb697008b8
--- /dev/null
+++ b/recipes/strace/strace_4.5.14.bb
@@ -0,0 +1,45 @@
+DESCRIPTION = "strace is a system call tracing tool."
+SECTION = "console/utils"
+LICENSE = "GPL"
+PR = "r7"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
+ file://glibc-2.5.patch;patch=1 \
+ file://arm-eabi.patch;patch=1 \
+ file://drop-ctl-proc.patch;patch=1 \
+ file://sh-arch-update.patch;patch=1 \
+ file://sh-syscall-update.patch;patch=1 \
+ file://strace-fix-arm-bad-syscall.patch;patch=1 \
+ file://strace-undef-syscall.patch;patch=1 \
+ file://strace-arm-no-cachectl.patch;patch=1 \
+ "
+
+# The strace-4.5.14-avr32.patch conflicts with some other patches.
+# These patches are primarly for the ARM and SuperH, so we'll just
+# not use them when building for the AVR32.
+# The avr32 patch also includes the drop-ctl-proc.patch
+# The AVR32 patches are from http://avr32linux.org/twiki/bin/view/Main/STrace
+SRC_URI_avr32 = \
+ "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
+ file://strace-4.5.14-avr32.patch;patch=1 \
+ file://strace-4.5.14-avr32-add-syscalls-up-to-sysvipc.patch;patch=1 \
+ "
+
+# Again, a different set of patches for MIPS. See http://bugs.openembedded.net/show_bug.cgi?id=2221
+MIPS = "\
+ ${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
+ file://glibc-2.5.patch;patch=1 \
+ file://arm-eabi.patch;patch=1 \
+ file://sh-arch-update.patch;patch=1 \
+ file://sh-syscall-update.patch;patch=1 \
+ file://strace-fix-arm-bad-syscall.patch;patch=1 \
+ file://strace-undef-syscall.patch;patch=1 \
+ file://strace-arm-no-cachectl.patch;patch=1 \
+ file://mips-sigcontext.patch;patch=1 \
+"
+SRC_URI_mips = "${MIPS}"
+SRC_URI_mipsel = "${MIPS}"
+
+inherit autotools
+
+export INCLUDES = "-I. -I./linux"