summaryrefslogtreecommitdiff
path: root/recipes/squashfs-tools/squashfs-tools_4.0.bb
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-11-18 01:29:09 +0100
committerLeon Woestenberg <leon@sidebranch.com>2009-11-18 19:22:12 +0100
commit1481ac48dd9d47cc6ac2749e1d68147553e76c7e (patch)
tree4789902fcca97ca886d9af8cd030473bd76f2071 /recipes/squashfs-tools/squashfs-tools_4.0.bb
parent96fa2bacf66afcb30903cea6a8ef3f612dbe2afc (diff)
squashfs-4.0: update squashfs-tools to include upstream LZMA inclusion.
In OpenEmbedded we used squashfs 4.0 with external patch for LZMA compression support. In the meantime, squashfs has mainlined LZMA support in its CVS version. This patches switches to the upstream squashfs-tools and modifies bitbake.conf to match the slightly different arguments to mksquashfs. Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
Diffstat (limited to 'recipes/squashfs-tools/squashfs-tools_4.0.bb')
-rw-r--r--recipes/squashfs-tools/squashfs-tools_4.0.bb42
1 files changed, 32 insertions, 10 deletions
diff --git a/recipes/squashfs-tools/squashfs-tools_4.0.bb b/recipes/squashfs-tools/squashfs-tools_4.0.bb
index 17ab6dc61b..4e18489e7b 100644
--- a/recipes/squashfs-tools/squashfs-tools_4.0.bb
+++ b/recipes/squashfs-tools/squashfs-tools_4.0.bb
@@ -1,14 +1,36 @@
-require squashfs-tools.inc
-DEPENDS += "lzma"
-PR = "${INC_PR}.1"
+DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
+SECTION = "base"
+LICENSE = "GPLv2"
+DEPENDS = "zlib"
+PR = "r2"
-EXTRA_OEMAKE = "USE_LZMA=1 \
- LZMA_CFLAGS='-I${STAGING_INCDIR}/lzma -DUSE_LZMA' \
- LZMA_LIB='${STAGING_LIBDIR}/liblzma.a'"
+# 2009-10-22 snapshot
+#SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/pkl/squashfs4.0-lzma-snapshot.tgz"
+#S = "${WORKDIR}/squashfs4.0-lzma-snapshot/squashfs-tools"
-DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_angstrom = "1"
+SRC_URI = "cvs://anonymous@squashfs.cvs.sourceforge.net/cvsroot/squashfs;module=squashfs;date=${SRCDATE}"
+S = "${WORKDIR}/squashfs/squashfs-tools"
-SRC_URI += " file://portability.patch;patch=1;pnum=2 \
- file://lzma-support.patch;patch=1;pnum=2"
+SRC_URI += "http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2"
+
+COMP_DEFAULT = gzip
+
+EXTRA_OEMAKE += "LZMA_SUPPORT=1 LZMA_DIR=../.."
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+# the COMP_DEFAULT macro should result in a string including quotes: "gzip"
+CFLAGS_append = ' -I. -I../../C -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
+ -D_GNU_SOURCE -DLZMA_SUPPORT -DCOMP_DEFAULT=\\"${COMP_DEFAULT}\\" '
+
+prefix = ""
+
+do_compile() {
+ oe_runmake mksquashfs
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 mksquashfs ${D}${sbindir}/
+}