summaryrefslogtreecommitdiff
path: root/recipes/shr/shr-specs_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-15 21:51:37 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-15 21:51:37 +0100
commitc010062f3c2abd1471512c4275f3cb6ed9513661 (patch)
tree867a143d48e15e1497393c5bf14e128975ea44da /recipes/shr/shr-specs_git.bb
parent6824a826530a26992854e727234e692d5427caf0 (diff)
parent6187540bc302a541ef90fd0069a64a194b1f7348 (diff)
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/shr/shr-specs_git.bb')
-rw-r--r--recipes/shr/shr-specs_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/shr/shr-specs_git.bb b/recipes/shr/shr-specs_git.bb
new file mode 100644
index 0000000000..bc29ee5e27
--- /dev/null
+++ b/recipes/shr/shr-specs_git.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "The SHR DBus API Specification"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "BSD"
+SECTION = "devel/specifications"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-specs.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+do_compile() {
+ make xml
+}
+
+do_stage() {
+ install -d "${STAGING_DATADIR}/shr-specs"
+ install -m 0644 xml/* "${STAGING_DATADIR}/shr-specs"
+}
+
+FILE_${PN}-dev += "${datadir}/shr-specs"
+
+