summaryrefslogtreecommitdiff
path: root/recipes/shr/ophonekitd_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-23 00:15:58 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-23 00:15:58 +0200
commit00f166d4fdb5ff5b966daa12a7a29cbbeeec4e8c (patch)
treea8666fdaac1553e139a05b91ca2bcfa1563e1732 /recipes/shr/ophonekitd_git.bb
parentda4dfa8b6fb0750c8013cf05209e3aeedaccee66 (diff)
parent9887524ae3b1acd6ece8d85eaab2a6c7b5c8e1aa (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/shr/ophonekitd_git.bb')
-rw-r--r--recipes/shr/ophonekitd_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/shr/ophonekitd_git.bb b/recipes/shr/ophonekitd_git.bb
new file mode 100644
index 0000000000..ed561c7c75
--- /dev/null
+++ b/recipes/shr/ophonekitd_git.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Ophonekitd daemon"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui sqlite3"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r18"
+
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -d ${D}${datadir}/ophonekitd/
+ install -d ${D}${localstatedir}/db
+ install -m 0755 ${S}/data/80ophonekitd ${D}${sysconfdir}/X11/Xsession.d/
+ install -m 0755 ${S}/data/ophonekitd.conf ${D}${sysconfdir}/dbus-1/system.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+