summaryrefslogtreecommitdiff
path: root/recipes/scummvm/scummvm_0.6.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/scummvm/scummvm_0.6.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/scummvm/scummvm_0.6.0.bb')
-rw-r--r--recipes/scummvm/scummvm_0.6.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/scummvm/scummvm_0.6.0.bb b/recipes/scummvm/scummvm_0.6.0.bb
new file mode 100644
index 0000000000..6ff76e6eb2
--- /dev/null
+++ b/recipes/scummvm/scummvm_0.6.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Virtual Machine for LucasArts Adventures for Qt/Embedded based palmtop environments w/ SDL."
+SECTION = "opie/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe tremor libogg zlib \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad mpeg2dec', d)}"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/scummvm/scummvm-${PV}.tar.bz2 \
+ file://sword1.patch;patch=1 \
+ file://tremor.patch;patch=1 \
+ file://mouse.patch;patch=1 "
+PR="r1"
+
+inherit autotools
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+EXTRA_OECONF = "--host=${HOST_SYS} \
+ --backend=sdl \
+ --disable-alsa \
+ --with-ogg-prefix=${STAGING_LIBDIR}/.. \
+ --with-vorbis-prefix=${STAGING_LIBDIR}/.. \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mpeg2', '--with-mpeg2-prefix=${STAGING_LIBDIR}/..', d)} \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mad', '--with-mad-prefix=${STAGING_BINDIR_CROSS}/..', d)} \
+ "
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 scummvm ${D}${bindir}/scummvm
+}
+