summaryrefslogtreecommitdiff
path: root/recipes/sarg/sarg_2.2.7.1.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-04-01 17:06:04 +0400
committerRoman I Khimov <khimov@altell.ru>2010-04-08 22:35:56 +0400
commit9614d5509e163e4515e329c334cfd250efa4deab (patch)
tree77edf18b9135276e0f30313fa9d188b0cba90273 /recipes/sarg/sarg_2.2.7.1.bb
parent56083e9b320c96f45a8a8756b2e7a0e9b2a7345c (diff)
sarg: new recipe
Squid Analysis Report Generator is a tool that allow you to view "where" your users are going to on the Internet. Sarg provides many informations about Squid users activities: times, bytes, sites, etc... Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/sarg/sarg_2.2.7.1.bb')
-rw-r--r--recipes/sarg/sarg_2.2.7.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/sarg/sarg_2.2.7.1.bb b/recipes/sarg/sarg_2.2.7.1.bb
new file mode 100644
index 0000000000..38283d87f9
--- /dev/null
+++ b/recipes/sarg/sarg_2.2.7.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Squid Analysis Report Generator"
+SECTION = "utils"
+DEPENDS = "gd"
+RSUGGESTS = "squid"
+LICENSE = "GPL"
+HOMEPAGE = "http://sarg.sourceforge.net/sarg.php"
+PR = "r0"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/sarg/sarg-${PV}.tar.gz;name=tar \
+ file://sarg.conf \
+ "
+SRC_URI[tar.md5sum] = "0ce83323978e715ce70a6d2ab4f0daa4"
+SRC_URI[tar.sha256sum] = "209398e7690876ef9df04ba7f0b4b47c91ea8cdcfd7a54d78f15b5548a2dd32e"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DSYSCONFDIR:STRING=${sysconfdir}/squid"
+
+do_install_append() {
+ install -m 0644 ${WORKDIR}/sarg.conf ${D}${sysconfdir}/squid/sarg.conf
+}