summaryrefslogtreecommitdiff
path: root/recipes/rtaudio/librtaudio_3.0.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/rtaudio/librtaudio_3.0.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/rtaudio/librtaudio_3.0.1.bb')
-rw-r--r--recipes/rtaudio/librtaudio_3.0.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/rtaudio/librtaudio_3.0.1.bb b/recipes/rtaudio/librtaudio_3.0.1.bb
new file mode 100644
index 0000000000..9549076ee5
--- /dev/null
+++ b/recipes/rtaudio/librtaudio_3.0.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "RtAudio is a set of C++ classes which provide a common API \
+for realtime audio input/output across Linux (native ALSA, JACK, and OSS), \
+Macintosh OS X, SGI, and Windows (DirectSound and ASIO) operating systems."
+SECTION = "libs"
+LICENSE = "rtaudio"
+HOMEPAGE = "http://www.music.mcgill.ca/~gary/rtaudio"
+DEPENDS = "alsa-lib"
+PR = "r0"
+
+SRC_URI = "http://music.mcgill.ca/~gary/rtaudio/release/rtaudio-${PV}.tar.gz"
+S = "${WORKDIR}/rtaudio-${PV}"
+
+inherit qmake qt3x11
+
+do_configure_prepend() {
+ qmake -project -t lib -nopwd *.cpp *.h
+}
+
+EXTRA_QMAKEVARS_POST = "CONFIG=console CONFIG+=thread DEFINES+=__LINUX_OSS__ DEFINES+=__LINUX_ALSA__ LIBS+=-lasound"
+
+do_stage() {
+ install -m 0644 *.h ${STAGING_INCDIR}
+ oe_libinstall -so librtaudio-3.0.1 ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_libinstall -so librtaudio-3.0.1 ${D}${libdir}
+}