summaryrefslogtreecommitdiff
path: root/recipes/rt2x00/rt3070_2.1.1.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-22 16:22:30 +0100
committerKoen Kooi <koen@openembedded.org>2010-04-12 19:43:29 +0200
commitbb3c6f24758b490366543e7392dd13cdcb200b6f (patch)
tree682049818f80651900d07e7c4bf91037170d55fd /recipes/rt2x00/rt3070_2.1.1.0.bb
parent616f5f6d11a71401eb6dbd4585db972178b2b339 (diff)
rt3070: also install .bin file, move to directory with other ralink recipes
Diffstat (limited to 'recipes/rt2x00/rt3070_2.1.1.0.bb')
-rw-r--r--recipes/rt2x00/rt3070_2.1.1.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/rt2x00/rt3070_2.1.1.0.bb b/recipes/rt2x00/rt3070_2.1.1.0.bb
new file mode 100644
index 0000000000..324471ad8f
--- /dev/null
+++ b/recipes/rt2x00/rt3070_2.1.1.0.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Ralink 3070"
+SECTION = "kernel/modules"
+LICENSE = "GPLv2"
+PR = "r2"
+
+inherit module
+
+SRC_URI = "http://www.ralinktech.com.tw/data/drivers/2009_0525_RT3070_Linux_STA_v${PV}.tar.bz2 \
+ file://makefile.patch;patch=1 \
+ file://config.patch;patch=1 \
+ "
+
+EXTRA_OEMAKE = "LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+S = "${WORKDIR}/2009_0525_RT3070_Linux_STA_v${PV}"
+
+do_install() {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -m 0644 ${S}/os/linux/rt3070sta.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ install -d ${D}/etc/Wireless/RT2870STA
+ install -m 0644 ${S}/RT2870STA.dat ${D}/etc/Wireless/RT2870STA
+ install -d ${D}/lib/firmware
+ install -m 0644 ${S}/common/*.bin ${D}/lib/firmware/
+}
+
+PACKAGES =+ "${PN}-firmware"
+FILES_${PN}-firmware = "/etc /lib/firmware"
+
+RDEPENDS_${PN} = "${PN}-firmware"