summaryrefslogtreecommitdiff
path: root/recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb')
-rw-r--r--recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb b/recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb
new file mode 100644
index 0000000000..3932bd5f98
--- /dev/null
+++ b/recipes/rocksndiamonds/rocksndiamonds_3.2.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Rocks'n'Diamonds - Boulderdash/Emerald Mine/Supaplex/Sokoban clone."
+SECTION = "games"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.artsoft.org/rocksndiamonds/"
+AUTHOR = "Holger Schemel <info@artsoft.org>"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://artsoft.org/RELEASES/unix/rocksndiamonds/rocksndiamonds-${PV}.tar.gz \
+ file://rocksndiamonds.png"
+
+DEPENDS += "libsdl-net smpeg"
+
+APPIMAGE = "../rocksndiamonds.png"
+EXTRA_OEMAKE = "CC='${CC}' AR='${AR}' RANLIB='${RANLIB}' RO_GAME_DIR='${datadir}/${PN}' RW_GAME_DIR='${datadir}/${PN}'"
+
+inherit sdl
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ${PN} ${D}${bindir}
+ install -d ${D}${datadir}/${PN}
+ cp -r graphics levels music scores sounds ${D}${datadir}/${PN}/
+}
+
+
+FILES_${PN} += "${bindir}/${PN} ${datadir}/${PN}"