summaryrefslogtreecommitdiff
path: root/recipes/regina-rexx/regina-rexx_3.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/regina-rexx/regina-rexx_3.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/regina-rexx/regina-rexx_3.3.bb')
-rw-r--r--recipes/regina-rexx/regina-rexx_3.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/regina-rexx/regina-rexx_3.3.bb b/recipes/regina-rexx/regina-rexx_3.3.bb
new file mode 100644
index 0000000000..8634c7f89b
--- /dev/null
+++ b/recipes/regina-rexx/regina-rexx_3.3.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "A cross-platform REXX interpreter"
+SECTION = "devel/rexx"
+LICENSE = "GPL"
+HOMEPAGE = "http://regina-rexx.sf.net"
+DEPENDS = "regina-rexx-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/regina-rexx/regina33.zip \
+ file://use-proper-host-tools.patch;patch=1"
+S = "${WORKDIR}"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+# need to use configure script built by ancient autotools
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake STAGING_BINDIR_NATIVE="${STAGING_BINDIR_NATIVE}"
+}
+
+do_install() {
+ oe_runmake install bindir="${D}${bindir}" libdir="${D}${libdir}" includedir="${D}${includedir}" \
+ sharedir="${D}${datadir}" mandir="${D}${mandir}" sysconfdir="${D}${sysconfdir}" \
+ STAGING_BINDIR_NATIVE="${STAGING_BINDIR_NATIVE}"
+}
+
+FILES_${PN} += "${datadir}"
+