summaryrefslogtreecommitdiff
path: root/recipes/rcs/rcs_5.7.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-12-28 16:46:06 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-12-28 16:46:06 +0100
commit9ad9958d6f27c98f986138d9d5b8719d4924a43f (patch)
tree0ec0910196038a23d931d96e7bac3fe100be2f7e /recipes/rcs/rcs_5.7.bb
parent4f4f16421c889272806916278c9c0a07aba8158f (diff)
rcs: new recipe; a revision control system. Closes OE #5050
Diffstat (limited to 'recipes/rcs/rcs_5.7.bb')
-rw-r--r--recipes/rcs/rcs_5.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/rcs/rcs_5.7.bb b/recipes/rcs/rcs_5.7.bb
new file mode 100644
index 0000000000..8e082951ee
--- /dev/null
+++ b/recipes/rcs/rcs_5.7.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "The Revision Control System (RCS) manages multiple revisions of files."
+HOMEPAGE = "http://www.cs.purdue.edu/homes/trinkle/RCS/"
+SECTION = "console/network"
+LICENSE = "RCS"
+PR = "r0"
+
+SRC_URI = "\
+ http://www.cs.purdue.edu/homes/trinkle/RCS/rcs-${PV}.tar.Z \
+ file://fix-installpath.patch;patch=1 \
+ file://oe-src-conf.h \
+"
+
+inherit autotools
+
+EXTRA_OECONF += "--with-diffutils"
+
+do_compile_prepend() {
+ install -m 0644 ${WORKDIR}/oe-src-conf.h ${S}/src/conf.h
+}
+
+RDEPENDS = "diffutils"