summaryrefslogtreecommitdiff
path: root/recipes/qt4/qt4-tools-sdk_4.5.1.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-10 13:40:27 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-10 13:40:27 +0200
commit0399441c0781eb912d6c375533fd60c69573809e (patch)
tree3e1d3a4310a9a990273dca40ef68d6df828ffbb7 /recipes/qt4/qt4-tools-sdk_4.5.1.bb
parentaa45c16c5c2bee16f5827f269bb305b00c266972 (diff)
parent4edd8b112d7b6ff108eda52db600861d90f5cf8d (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/qt4/qt4-tools-sdk_4.5.1.bb')
-rw-r--r--recipes/qt4/qt4-tools-sdk_4.5.1.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/recipes/qt4/qt4-tools-sdk_4.5.1.bb b/recipes/qt4/qt4-tools-sdk_4.5.1.bb
new file mode 100644
index 0000000000..db919fd6df
--- /dev/null
+++ b/recipes/qt4/qt4-tools-sdk_4.5.1.bb
@@ -0,0 +1,72 @@
+DESCRIPTION = "SDK tools for Qt/[X11|Mac|Embedded] version 4.x"
+DEPENDS = "zlib-native dbus-native"
+SECTION = "libs"
+HOMEPAGE = "http://www.trolltech.com"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+inherit sdk
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://configure-lflags.patch;patch=1 \
+ file://qt-config.patch;patch=1 \
+ file://g++.conf \
+ file://linux.conf"
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+
+# FIXME: make it work with "${STAGING_BINDIR_NATIVE}/pkg-config --cflags dbus-1"
+EXTRA_OECONF = "-prefix ${prefix} \
+ -qt-libjpeg -qt-gif -system-zlib \
+ -no-libjpeg -no-libpng \
+ -no-accessibility \
+ -no-cups \
+ -no-exceptions \
+ -no-nas-sound \
+ -no-nis \
+ -verbose -release -fast -static \
+ -qt3support \
+ -I${STAGING_DIR_NATIVE}/usr/include \
+ -I${STAGING_DIR_NATIVE}/usr/include/dbus-1.0 \
+ -I${STAGING_DIR_NATIVE}/usr/lib/dbus-1.0/include"
+
+# yank default -e, otherwise we get the following error:
+# moc_qbuffer.cpp: No such file or directory
+EXTRA_OEMAKE = " "
+
+do_configure() {
+ (echo o; echo yes) | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
+}
+
+TOBUILD = "\
+ src/tools/bootstrap \
+ src/tools/moc \
+ src/corelib \
+ src/sql \
+ src/dbus \
+ src/qt3support \
+ src/xml \
+ src/tools/uic \
+ src/tools/rcc \
+ src/network \
+ src/gui \
+ src/tools/uic3 \
+ tools/linguist/lrelease \
+ tools/linguist/lupdate \
+ tools/qdbus \
+"
+
+do_compile() {
+ for i in ${TOBUILD}; do
+ cd ${S}/$i && oe_runmake CC="${CC}" CXX="${CXX}"
+ done
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}/
+ install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake2
+ for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
+ install -m 0755 bin/${i} ${STAGING_BINDIR_NATIVE}/${i}4
+ done
+}
+
+