summaryrefslogtreecommitdiff
path: root/recipes/qt4/qt4-embedded_4.5.0.bb
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-03-26 19:59:18 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2009-03-26 19:59:18 +0100
commitd3224e2c27fa9e92f2e5bbfeb562a39e1b0f6065 (patch)
treedff26424021cc42bc03fd4a091be42aebbec12cb /recipes/qt4/qt4-embedded_4.5.0.bb
parent951b573a5b4bab60ba2c42b6dc7e1689a94c42eb (diff)
qt4-embedded: add version 4.5.0
Diffstat (limited to 'recipes/qt4/qt4-embedded_4.5.0.bb')
-rw-r--r--recipes/qt4/qt4-embedded_4.5.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/qt4/qt4-embedded_4.5.0.bb b/recipes/qt4/qt4-embedded_4.5.0.bb
new file mode 100644
index 0000000000..90a3b28a8f
--- /dev/null
+++ b/recipes/qt4/qt4-embedded_4.5.0.bb
@@ -0,0 +1,40 @@
+SUMMARY = "Qt is a versatile cross-platform application framework -- this is the embedded version."
+SECTION = "libs"
+LICENSE = "GPL LGPL QPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+DEPENDS += "tslib"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://${PV}/0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://${PV}/0006-freetype-host-includes.patch;patch=1 \
+ file://${PV}/0007-openssl-host-includes.patch;patch=1 \
+ file://${PV}/0008-qt-lib-infix.patch;patch=1 \
+ file://0009-support-2bpp.patch;patch=1 \
+ file://${PV}/0010-no-simpledecoration-example.patch;patch=1 \
+ file://g++.conf \
+ file://linux.conf \
+ "
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+
+QT_CONFIG_FLAGS += " \
+ -qtlibinfix E \
+ -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
+ -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc \
+ -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb \
+ -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb \
+ -DQT_KEYPAD_NAVIGATION \
+ "
+
+QT_BASE_NAME = "qt-embedded"
+QT_BASE_LIB = "libqt-embedded"
+QT_DIR_NAME = "qtopia"
+QT_LIBINFIX="E"
+
+require qt4.inc
+
+inherit qt4e