summaryrefslogtreecommitdiff
path: root/recipes/qt4/qt4-embedded_4.4.3.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@koansoftware.com>2009-03-26 11:10:03 +0100
committerMarcin Juszkiewicz <hrw@koansoftware.com>2009-03-26 11:10:03 +0100
commita7be854977d7ad7c8460fee76739db8154e83049 (patch)
tree3696192bc8abcae8ce4e0121df2dd4e5246541df /recipes/qt4/qt4-embedded_4.4.3.bb
parente2718269c5f56774705478545316a879f0be82c4 (diff)
parent1b045e71ce7c3b7ed6c68ae1d60e974edbe38efc (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/qt4/qt4-embedded_4.4.3.bb')
-rw-r--r--recipes/qt4/qt4-embedded_4.4.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/qt4/qt4-embedded_4.4.3.bb b/recipes/qt4/qt4-embedded_4.4.3.bb
new file mode 100644
index 0000000000..015b48e597
--- /dev/null
+++ b/recipes/qt4/qt4-embedded_4.4.3.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Qt is a versatile cross-platform application framework -- this is the embedded version."
+SECTION = "libs"
+LICENSE = "GPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+DEPENDS += "tslib"
+PR = "r9"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0005-fix-mkspecs.patch;patch=1 \
+ file://0006-freetype-host-includes.patch;patch=1 \
+ file://0007-openssl-host-includes.patch;patch=1 \
+ file://0008-qt-lib-infix.patch;patch=1 \
+ file://0009-support-2bpp.patch;patch=1 \
+ "
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+
+QT_CONFIG_FLAGS += " \
+ -qtlibinfix E \
+ -qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows \
+ -plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc \
+ -plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb \
+ -qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb \
+ -DQT_KEYPAD_NAVIGATION \
+ "
+
+QT_BASE_NAME = "qt-embedded"
+QT_BASE_LIB = "libqt-embedded"
+QT_DIR_NAME = "qtopia"
+QT_LIBINFIX="E"
+
+require qt4.inc
+
+inherit qt4e