summaryrefslogtreecommitdiff
path: root/recipes/qpphoto/qpphoto_1.0.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/qpphoto/qpphoto_1.0.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/qpphoto/qpphoto_1.0.2.bb')
-rw-r--r--recipes/qpphoto/qpphoto_1.0.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/qpphoto/qpphoto_1.0.2.bb b/recipes/qpphoto/qpphoto_1.0.2.bb
new file mode 100644
index 0000000000..9ef9b4ef3a
--- /dev/null
+++ b/recipes/qpphoto/qpphoto_1.0.2.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Painting program. Small picture editor."
+HOMEPAGE = "http://zaurus.colognearts.de/qpphoto/"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "qpPhoto"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+PR = "r0"
+
+inherit opie
+
+SRC_URI = "http://zaurus.colognearts.de/qpphoto/qpPhoto_1.0.2_src.tar.gz \
+ file://draw.patch;patch=1 \
+ file://drawview.patch;patch=1 \
+ file://drawwidget.patch;patch=1 "
+
+S = "${WORKDIR}/qpPhoto_1.0.2"
+
+do_compile() {
+ export STAGING_BINDIR=${STAGING_BINDIR}
+ oe_runmake clean
+ oe_runmake
+}
+
+do_install() {
+# install -d ${D}${palmtopdir}/apps/Applications
+ install -d ${D}${palmtopdir}/pics
+# install -d ${D}${bindir}
+
+ install -m 0644 qpPhoto.png ${D}${palmtopdir}/pics
+# install -m 0644 qpPhoto.desktop ${D}${palmtopdir}/apps/Applications
+# install -m 0755 qpPhoto ${D}${bindir}
+}
+
+# FILES_${PN} = " ${palmtopdir}/apps/Applications/qpPhoto.desktop ${palmtopdir}/pics/qpPhoto.png ${bindir}/qpPhoto "