summaryrefslogtreecommitdiff
path: root/recipes/qemu/qemu_0.12.3.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-08 11:50:21 +0300
committerJesse Gilles <jgilles@multitech.com>2010-04-26 11:35:50 -0500
commit2b0109cdd8be5a58d230db249da51abf617d2ca0 (patch)
tree4ed1cd5ac707262ca98965e13618adac78faf5f6 /recipes/qemu/qemu_0.12.3.bb
parent89f3a006a15986d045cddc0f405ecac78d11bb9a (diff)
qemu: add version 0.12.3
qemu-native tested to compile on openSUSE 11.2 and Debian Lenny. Binary locale generation tested for qemuarm/glibc, simpad/glibc, x86-prescott/eglibc, efika/glibc. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/qemu/qemu_0.12.3.bb')
-rw-r--r--recipes/qemu/qemu_0.12.3.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/qemu/qemu_0.12.3.bb b/recipes/qemu/qemu_0.12.3.bb
new file mode 100644
index 0000000000..035b1a5b3a
--- /dev/null
+++ b/recipes/qemu/qemu_0.12.3.bb
@@ -0,0 +1,36 @@
+LICENSE = "GPL"
+DEPENDS = "zlib"
+
+PR = "r0"
+
+SRC_URI = "\
+ http://download.savannah.gnu.org/releases/qemu/qemu-${PV}.tar.gz;name=qemu-${PV} \
+ file://06_exit_segfault.patch;patch=1;pnum=0 \
+ file://11_signal_sigaction.patch;patch=1;pnum=0 \
+ file://22_net_tuntap_stall.patch;patch=1 \
+ file://31_syscalls.patch;patch=1;pnum=0 \
+ file://32_syscall_sysctl.patch;patch=1;pnum=0 \
+ file://52_ne2000_return.patch;patch=1 \
+ file://63_sparc_build.patch;patch=1;pnum=0 \
+ file://64_ppc_asm_constraints.patch;patch=1 \
+ file://66_tls_ld.patch;patch=1;pnum=0 \
+ file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
+ file://fix_segfault.patch;patch=1 \
+ file://fix_baum_c_compilation.patch;patch=1 \
+ file://fix_fortify_source_compilation.patch;patch=1 \
+ "
+
+SRC_URI[qemu-0.12.3.sha256sum] = "3ce26f8fb0a59418b2064a26bac4b40ea4e493acbc3df7ad5932635477fade4b"
+SRC_URI[qemu-0.12.3.md5sum] = "d215e4568650e8019816397174c090e1"
+
+BBCLASSEXTEND="native"
+
+S = "${WORKDIR}/qemu-${PV}"
+
+EXTRA_OECONF += "--disable-sdl --disable-strip"
+
+inherit autotools
+
+do_configure() {
+ ${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
+}