summaryrefslogtreecommitdiff
path: root/recipes/python/python-pygame_1.8.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-pygame_1.8.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-pygame_1.8.1.bb')
-rw-r--r--recipes/python/python-pygame_1.8.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/python/python-pygame_1.8.1.bb b/recipes/python/python-pygame_1.8.1.bb
new file mode 100644
index 0000000000..95191ce350
--- /dev/null
+++ b/recipes/python/python-pygame_1.8.1.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Python libSDL Bindings"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.pygame.org"
+LICENSE = "LGPL"
+DEPENDS = "libsdl-x11 libsdl-image libsdl-mixer libsdl-net libsdl-ttf python-numeric"
+DEPENDS += "${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'smpeg', d)}"
+SRCNAME = "pygame"
+PR = "ml4"
+
+SRC_URI = "\
+ ftp://ftp.pygame.org/pub/pygame/${SRCNAME}-${PV}release.tar.gz \
+ file://Setup \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}release"
+
+inherit distutils
+
+do_configure_prepend() {
+ cat ${WORKDIR}/Setup >Setup
+ SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >>Setup
+ if [ '${ENTERPRISE_DISTRO}' != '1' ]; then
+ echo "movie src/movie.c \$(SDL) \$(SMPEG) \$(DEBUG)" >>Setup
+ fi
+}
+
+do_stage() {
+ distutils_stage_all
+}
+
+RDEPENDS = "python-numeric"