summaryrefslogtreecommitdiff
path: root/recipes/python/python-2.6.5/03-fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-08-16 21:35:34 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-17 10:34:01 +0200
commitb16899ec9eadd8ccae74e31484fa7161798a6445 (patch)
treeeefab896bd3a34640dce30591f57c8abb10afd7c /recipes/python/python-2.6.5/03-fix-tkinter-detection.patch
parenta5052d3889a383cd257b7dbb9bf3dedef8cdd5fe (diff)
python: import 2.6.5 from poky
* without legacy staging * fix QA issue libpython2: non -dev package contains symlink .so: libpython2 path * use FILESPATHPKG Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Michael 'Mickey' Lauer <mickey@vanille-media.de>
Diffstat (limited to 'recipes/python/python-2.6.5/03-fix-tkinter-detection.patch')
-rw-r--r--recipes/python/python-2.6.5/03-fix-tkinter-detection.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/python/python-2.6.5/03-fix-tkinter-detection.patch b/recipes/python/python-2.6.5/03-fix-tkinter-detection.patch
new file mode 100644
index 0000000000..a1a385a07c
--- /dev/null
+++ b/recipes/python/python-2.6.5/03-fix-tkinter-detection.patch
@@ -0,0 +1,40 @@
+# We need to supply STAGING_INCDIR here, otherwise the Tk headers
+# will not be found.
+# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille.de>
+
+Index: Python-2.6.1/setup.py
+===================================================================
+--- Python-2.6.1.orig/setup.py
++++ Python-2.6.1/setup.py
+@@ -1543,7 +1543,7 @@ class PyBuildExt(build_ext):
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1562,22 +1562,6 @@ class PyBuildExt(build_ext):
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)