summaryrefslogtreecommitdiff
path: root/recipes/pocketcellar/pocketcellar_1.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pocketcellar/pocketcellar_1.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pocketcellar/pocketcellar_1.1.bb')
-rw-r--r--recipes/pocketcellar/pocketcellar_1.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/pocketcellar/pocketcellar_1.1.bb b/recipes/pocketcellar/pocketcellar_1.1.bb
new file mode 100644
index 0000000000..84fc53fa87
--- /dev/null
+++ b/recipes/pocketcellar/pocketcellar_1.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Wine cellar manager. Allows you to record details of wines and \
+those you have in your cellar. The Food Assistant will make suggestions of wines \
+suitable for your meal, and indicate those in your cellar that match."
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "http://www.staikos.net/~staikos/pocketcellar/pocketcellar-${PV}.tar.gz \
+ file://winedb.patch;patch=1 \
+ file://cellardb.patch;patch=1 \
+ file://pocketcellar.patch;patch=1 \
+ file://gcc3.patch;patch=1"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += " DESTDIR=pkg-cellar/home/QtPalmtop/bin/"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/data/PocketCellar
+
+ install -m 644 pkg-pcellar/home/QtPalmtop/data/PocketCellar/* ${D}${palmtopdir}/data/PocketCellar/
+ install -m 755 pkg-cellar/home/QtPalmtop/bin/pocketcellar ${D}${palmtopdir}/bin/
+ install -m 644 pocketcellar.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 644 pocketcellar.png ${D}${palmtopdir}/pics/
+ install -m 644 pkg-pcellar/home/root/Settings/foodassist.conf ${D}${palmtopdir}/data/PocketCellar/
+}
+
+FILES_${PN} = "/"