summaryrefslogtreecommitdiff
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-09-02 16:12:20 -0700
committerTom Rini <tom_rini@mentor.com>2010-09-02 16:12:20 -0700
commita5ee14715405dd220a3ca4afa567134158dae4be (patch)
treed1ef1b64ad1bcd39c39b593d56b1daec420cfdaa /recipes/perl/perl_5.8.8.bb
parent261676fed0818a60a6f5b4dc781235cc6c49ba86 (diff)
perl: Use CCLD not ${TARGET_SYS}-gcc in do_compile
It's possible that CCLD != ${TARGET_SYS}-gcc once everything is evaluated and CCLD is for when you're using CC for LD. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index c8ad895e56..f106e17892 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r35"
+PR = "r36"
# Major part of version
PVM = "5.8"
@@ -108,7 +108,7 @@ do_compile() {
-e 's|$Config{cppflags}||' ext/Errno/Errno_pm.PL
fi
cd Cross
- oe_runmake perl LD="${TARGET_SYS}-gcc"
+ oe_runmake perl LD="${CCLD}"
}
do_install() {
oe_runmake install