summaryrefslogtreecommitdiff
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-11 21:01:47 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-11 21:02:36 +0000
commit25db6767cbf1b00a4e8dbf746d2d16458c3696ea (patch)
tree6f3bb096161bfd8567fcf0bb822f6f96b1607016 /recipes/perl/perl_5.8.8.bb
parent177ca0dc717faafb67d9fa2f6236eccc182b8038 (diff)
perl: Move config.sh to STAGING_LIBDIR rather than trying to be clever with staging variables and losing
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 35fcc83ccc..02ad7bf376 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -141,12 +141,11 @@ do_install() {
fi
}
do_stage() {
- install -d ${STAGING_DIR}/${HOST_SYS}/perl \
- ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
+ install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE \
${STAGING_DATADIR}/perl/${PV}/ExtUtils
# target config, used by cpan.bbclass to extract version information
- install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
+ install config.sh ${STAGING_LIBDIR}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# target configuration