summaryrefslogtreecommitdiff
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-10 22:16:43 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-10 22:16:43 +0100
commit09ebc69351c7e28b57ded8c95ee0d27b065e36a1 (patch)
treed9ee3ecdf3e7f42cf5cbfa120355f405656ec23a /recipes/perl/perl_5.8.8.bb
parentc028070df436ea6b94395e776c7fd7266b64e0a6 (diff)
perl: complete config.sh fix
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 2508719736..35fcc83ccc 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -141,12 +141,12 @@ do_install() {
fi
}
do_stage() {
- install -d ${STAGING_DIR_HOST}/perl \
+ install -d ${STAGING_DIR}/${HOST_SYS}/perl \
${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE \
${STAGING_DATADIR}/perl/${PV}/ExtUtils
# target config, used by cpan.bbclass to extract version information
- install config.sh ${STAGING_DIR_HOST}/perl/
+ install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# target configuration