summaryrefslogtreecommitdiff
path: root/recipes/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-07-07 10:04:27 -0700
committerTom Rini <tom_rini@mentor.com>2010-07-07 10:06:06 -0700
commit71a16be679041bb042c02f0f59c56141d963562c (patch)
tree8347f18665270c635292ef5f717aaf3c01d7f88a /recipes/perl/perl-native_5.8.8.bb
parent38b4324c740e4495dc352ee8514a4cce514c3f35 (diff)
perl-native: Add a CPAN/Config.pm file
Without this, cpan stuff can get in an infinite loop. We try and pick a good enough mirror but if needed could add CPAN_MIRROR to bitbake.conf and regex that in as well. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/perl/perl-native_5.8.8.bb')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index 336b419e95..fe1bc846fc 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -3,12 +3,13 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r19"
+PR = "r20"
NATIVE_INSTALL_WORKS = "1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/5.0/perl-${PV}.tar.gz \
+ file://CPAN-Config.pm \
file://perl-5.8.8-gcc-4.2.patch \
file://Configure-multilib.patch \
file://perl-configpm-switch.patch \
@@ -90,6 +91,9 @@ do_install() {
thread.h warnings.h; do
install $i ${D}${libdir}/perl/${PV}/CORE
done
+ # Make sure CPAN is configured
+ sed -e "s,@SYSROOTBASE@,${base_prefix}," ${WORKDIR}/CPAN-Config.pm > \
+ ${D}${libdir}/perl/${PV}/CPAN/Config.pm
}
do_install_append_nylon() {