summaryrefslogtreecommitdiff
path: root/recipes/perl/perl-native_5.8.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/perl/perl-native_5.8.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/perl/perl-native_5.8.7.bb')
-rw-r--r--recipes/perl/perl-native_5.8.7.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/perl/perl-native_5.8.7.bb b/recipes/perl/perl-native_5.8.7.bb
new file mode 100644
index 0000000000..ebb10e5580
--- /dev/null
+++ b/recipes/perl/perl-native_5.8.7.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Perl is a popular scripting language."
+HOMEPAGE = "http://www.perl.org/"
+LICENSE = "Artistic|GPL"
+PR = "r5"
+
+SECTION = "libs"
+inherit native
+
+DEPENDS = "virtual/db-native gdbm-native"
+
+SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
+ file://perl-5.8.8-gcc-4.2.patch;patch=1 \
+ file://Configure-multilib.patch;patch=1"
+S = "${WORKDIR}/perl-${PV}"
+
+#perl is not parallel_make safe
+PARALLEL_MAKE = ""
+
+do_configure () {
+ ./Configure \
+ -Dcc="${CC}" \
+ -Dcflags="${CFLAGS}" \
+ -Dldflags="$LDFLAGS}" \
+ -Dusethreads \
+ -Duselargefiles \
+ -Dprefix=${prefix} \
+ -Dvendorprefix=${prefix} \
+ -Dsiteprefix=${prefix}/local \
+ -Dman1ext=1 \
+ -Dman3ext=3perl \
+ -Uafs \
+ -Ud_csh \
+ -Uusesfio \
+ -Uusenm -des
+ sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
+ s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
+ mv config.sh.new config.sh
+}