summaryrefslogtreecommitdiff
path: root/recipes/perl/libnetaddr-ip-perl_4.027.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-24 20:20:50 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-24 20:20:50 +0300
commitc67a7e4b81aedc340399649f62e5a02036a80a48 (patch)
tree2e2092ddf4c6933a53d53b8d57e630c2895892b7 /recipes/perl/libnetaddr-ip-perl_4.027.bb
parent71341fee3cd2cac082be9534607d79256eeff05e (diff)
parent49fa8c1ad4c6e1ae5cb1c4e09105aa225ab735f6 (diff)
Merge branch 'perl-5.10' into org.openembedded.dev
Diffstat (limited to 'recipes/perl/libnetaddr-ip-perl_4.027.bb')
-rw-r--r--recipes/perl/libnetaddr-ip-perl_4.027.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/perl/libnetaddr-ip-perl_4.027.bb b/recipes/perl/libnetaddr-ip-perl_4.027.bb
new file mode 100644
index 0000000000..155b285173
--- /dev/null
+++ b/recipes/perl/libnetaddr-ip-perl_4.027.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Perl module to manage IPv4 and IPv6 addresses and subnets"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = "libtest-pod-perl-native"
+RDEPENDS_${PN} += "perl-module-test-more"
+BBCLASSEXTEND = "native"
+
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKER/NetAddr-IP-${PV}.tar.gz;name=netaddr-ip-perl-${PV}"
+SRC_URI[netaddr-ip-perl-4.027.md5sum] = "c4a21a76e5b1b9f4c8e9810b78559d7b"
+SRC_URI[netaddr-ip-perl-4.027.sha256sum] = "e26b76d65e83841ba618bbe9ea913159e5e0e14a1e611b3ff870ed41e60077e0"
+
+S = "${WORKDIR}/NetAddr-IP-${PV}"
+
+inherit cpan
+
+do_configure_prepend() {
+ cd Lite/Util
+ oenote Executing autoreconf --verbose --install --force
+ mkdir -p m4
+ autoreconf -Wcross --verbose --install --force || oefatal "autoreconf execution failed."
+ ./configure --build=${BUILD_SYS} --host=${HOST_SYS} \
+ --target=${TARGET_SYS} --prefix=${prefix} --exec_prefix=${exec_prefix} \
+ --bindir=${bindir} --sbindir=${sbindir} --libexecdir=${libexecdir} \
+ --datadir=${datadir} --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} --localstatedir=${localstatedir} \
+ --libdir=${libdir} --includedir=${includedir} \
+ --oldincludedir=${oldincludedir} --infodir=${infodir} --mandir=${mandir}
+ cd ${S}
+}