summaryrefslogtreecommitdiff
path: root/recipes/packagekit/packagekit_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/packagekit/packagekit_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/packagekit/packagekit_git.bb')
-rw-r--r--recipes/packagekit/packagekit_git.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/packagekit/packagekit_git.bb b/recipes/packagekit/packagekit_git.bb
new file mode 100644
index 0000000000..0e9793d050
--- /dev/null
+++ b/recipes/packagekit/packagekit_git.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "PackageKit package management abstraction"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "dbus (>= 1.1.1) dbus-glib glib-2.0 sqlite3 opkg intltool intltool-native (>= 0.37.1)"
+RDEPENDS_${PN} = "opkg"
+PV = "0.2.3+gitr${SRCREV}"
+PR = "r18"
+PE = "1"
+
+SRC_URI = "git://anongit.freedesktop.org/git/packagekit;protocol=git \
+ file://disable-docbook2man.patch;patch=1 \
+ file://repository-ping.patch;patch=1 \
+ file://force_depends.patch;patch=1 \
+ file://remove_search_memory_leak.patch;patch=1 \
+ file://racing_condition.patch;patch=1 \
+ file://modify_summary_and_adding_reposi_info.patch;patch=1 \
+ "
+
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-security-framework=dummy \
+ --with-default-backend=opkg \
+ --enable-opkg \
+ ac_cv_path_XMLTO=no \
+ "
+
+
+do_configure_prepend() {
+ echo "EXTRA_DIST=" > gtk-doc.make
+ sed -i -e s:0\.1\.5:0\.1\.6:g configure.ac
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/packagekit-backend/*.so ${datadir}/dbus-1/system-services/"
+FILES_${PN}-dbg += "${libdir}/packagekit-backend/.debug/*.so "