summaryrefslogtreecommitdiff
path: root/recipes/openssl/openssl-1.0.0/libdeps-first.patch
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-30 16:19:35 +0400
committerRoman I Khimov <khimov@altell.ru>2010-03-31 10:45:41 +0400
commit2f196b1407bd290a4a96d81e99534ccf04b33f1a (patch)
treec272fca3e7929ebee70737554b9adfc7297f380c /recipes/openssl/openssl-1.0.0/libdeps-first.patch
parentc1aab90e5ecc5e1e8c4c8d8c5050d41fe075c3a9 (diff)
openssl: add version 1.0.0
* DEFAULT_PREFERENCE = "-1", since it might break apps * enable engines build (and package those separately) Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/openssl/openssl-1.0.0/libdeps-first.patch')
-rw-r--r--recipes/openssl/openssl-1.0.0/libdeps-first.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/openssl/openssl-1.0.0/libdeps-first.patch b/recipes/openssl/openssl-1.0.0/libdeps-first.patch
new file mode 100644
index 0000000000..9c0037ab96
--- /dev/null
+++ b/recipes/openssl/openssl-1.0.0/libdeps-first.patch
@@ -0,0 +1,41 @@
+Links to previously staged 0.9.8* easily otherwise
+
+Index: openssl-1.0.0/Makefile.shared
+===================================================================
+--- openssl-1.0.0.orig/Makefile.shared Usage: date [OPTION]... [+FORMAT]
+Display the current time in the given FORMAT.
+
+ -d, --date=STRING display time described by STRING, not `now'
+ -f, --file=DATEFILE like --date once for each line of DATEFILE
+ -R, --rfc-822 output RFC-822 compliant date string
+ -u, --utc, --universal print or set Coordinated Universal Time
+ --help display this help and exit
++++ openssl-1.0.0/Makefile.shared Usage: date [OPTION]... [+FORMAT]
+Display the current time in the given FORMAT.
+
+ -d, --date=STRING display time described by STRING, not `now'
+ -f, --file=DATEFILE like --date once for each line of DATEFILE
+ -R, --rfc-822 output RFC-822 compliant date string
+ -u, --utc, --universal print or set Coordinated Universal Time
+ --help display this help and exit
+@@ -96,7 +96,7 @@
+ LIBPATH=`for x in $$LIBDEPS; do echo $$x; done | sed -e 's/^ *-L//;t' -e d | uniq`; \
+ LIBPATH=`echo $$LIBPATH | sed -e 's/ /:/g'`; \
+ LD_LIBRARY_PATH=$$LIBPATH:$$LD_LIBRARY_PATH \
+- $${LDCMD} $${LDFLAGS} -o $${APPNAME:=$(APPNAME)} $(OBJECTS) $${LIBDEPS} )
++ $${LDCMD} $${LIBDEPS} $${LDFLAGS} -o $${APPNAME:=$(APPNAME)} $(OBJECTS) )
+
+ LINK_SO= \
+ ( $(SET_X); \
+@@ -106,9 +106,9 @@
+ LIBPATH=`for x in $$LIBDEPS; do echo $$x; done | sed -e 's/^ *-L//;t' -e d | uniq`; \
+ LIBPATH=`echo $$LIBPATH | sed -e 's/ /:/g'`; \
+ LD_LIBRARY_PATH=$$LIBPATH:$$LD_LIBRARY_PATH \
+- $${SHAREDCMD} $${SHAREDFLAGS} \
++ $${SHAREDCMD} $$LIBDEPS $${SHAREDFLAGS} \
+ -o $$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX \
+- $$ALLSYMSFLAGS $$SHOBJECTS $$NOALLSYMSFLAGS $$LIBDEPS \
++ $$ALLSYMSFLAGS $$SHOBJECTS $$NOALLSYMSFLAGS \
+ ) && $(SYMLINK_SO)
+
+ SYMLINK_SO= \